summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-09-18 11:53:10 +0200
committerPacho Ramos <pacho@gentoo.org>2016-09-18 11:57:55 +0200
commit46534fb6572a75ccffe9cb60a888a437dd75e9ea (patch)
tree1d3dc04800a933af97d321e5a257154f888486cc
parent5f23e374f6a8439c97cb44738bc12dff7be787e3 (diff)
downloadgentoo-46534fb6572a75ccffe9cb60a888a437dd75e9ea.tar.gz
gentoo-46534fb6572a75ccffe9cb60a888a437dd75e9ea.tar.xz
net-misc/gwget: eapi6 bump
Package-Manager: portage-2.3.0
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch4
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild39
2 files changed, 21 insertions, 22 deletions
diff --git a/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
index 116cf60b992..8cecc197814 100644
--- a/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
+++ b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
@@ -1,5 +1,5 @@
---- src/systray.c
-+++ src/systray.c
+--- a/src/systray.c
++++ b/src/systray.c
@@ -6,6 +6,12 @@
#include "systray.h"
#include "main_window_cb.h"
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
index a50f14e0b93..51130179d77 100644
--- a/net-misc/gwget/gwget-1.0.4.ebuild
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
-GCONF_DEBUG="no"
+EAPI=6
GNOME2_LA_PUNT="yes"
GNOME_TARBALL_SUFFIX="bz2"
-inherit eutils gnome2
+inherit gnome2
DESCRIPTION="GTK2 WGet Frontend"
HOMEPAGE="https://gnome.org/projects/gwget/"
@@ -19,32 +18,32 @@ IUSE="epiphany libnotify"
# FIXME: dbus should be optional
# needs patching for linguas/intltool
-RDEPEND="net-misc/wget
+RDEPEND="
+ net-misc/wget
>=x11-libs/gtk+-2.6:2
>=dev-libs/glib-2.16.0:2
>=gnome-base/gconf-2:2
>=gnome-base/libgnomeui-2
>=dev-libs/dbus-glib-0.70
epiphany? ( >=www-client/epiphany-1.4 )
- libnotify? ( >=x11-libs/libnotify-0.2.2 )"
+ libnotify? ( >=x11-libs/libnotify-0.2.2 )
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
>=dev-util/intltool-0.35.0
- >=sys-devel/gettext-0.10.4"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
- G2CONF="${G2CONF}
- $(use_enable epiphany epiphany-extension)
- $(use_enable libnotify)
+ >=sys-devel/gettext-0.10.4
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+ "${FILESDIR}"/${P}-glib-single-include.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable epiphany epiphany-extension) \
+ $(use_enable libnotify) \
--disable-static
- --disable-schemas-install"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
- epatch "${FILESDIR}"/${P}-glib-single-include.patch
- gnome2_src_prepare
}
src_install() {