summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-23 19:53:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:12:04 +0200
commit4f3ce477f935a377f7d4f556aee328487f9e096d (patch)
tree397403732ad44929eb88e5ee892a0946c2d0d7de
parent559817ebfd659dd4a571b63a393c7054fca01f75 (diff)
downloadgentoo-4f3ce477f935a377f7d4f556aee328487f9e096d.tar.gz
gentoo-4f3ce477f935a377f7d4f556aee328487f9e096d.tar.xz
dev-python/extras: Add pypy3 support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/extras/extras-0.0.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/extras/extras-0.0.3.ebuild b/dev-python/extras/extras-0.0.3.ebuild
index d066a64c0dd..0dab6721b70 100644
--- a/dev-python/extras/extras-0.0.3.ebuild
+++ b/dev-python/extras/extras-0.0.3.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -16,11 +17,11 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
RDEPEND=""
python_test() {
"${PYTHON}" ${PN}/tests/test_extras.py || die
- einfo "test_extras passed under ${EPYTHON}"
}