summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-11-24 03:07:21 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-11-24 03:08:30 +1100
commit4f3eaa4f5c2d9a46d602f3b0d603bc0e2da66a9e (patch)
tree74f9871783b2a2b691ec51b58f65d11bf3d2269a
parent4090447b0cb0064a77db6725deb8213bb5138eff (diff)
downloadgentoo-4f3eaa4f5c2d9a46d602f3b0d603bc0e2da66a9e.tar.gz
gentoo-4f3eaa4f5c2d9a46d602f3b0d603bc0e2da66a9e.tar.xz
dev-qt/qt-docs: revision bump to remove colliding files
Gentoo-bug: 597026 Package-Manager: portage-2.3.2
-rw-r--r--dev-qt/qt-docs/qt-docs-5.6.2_p0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qt-docs/qt-docs-5.6.2_p0-r1.ebuild b/dev-qt/qt-docs/qt-docs-5.6.2_p0-r1.ebuild
new file mode 100644
index 00000000000..840bb45ebb3
--- /dev/null
+++ b/dev-qt/qt-docs/qt-docs-5.6.2_p0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
+MY_P=${PV/_p/-}qt-everywhere-documentation-${PV%%_p*}
+
+DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
+HOMEPAGE="https://www.qt.io/"
+SRC_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${MY_P}.7z"
+
+LICENSE="FDL-1.3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/p7zip"
+
+S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)
+
+src_install() {
+ # ${PV} instead of ${PF} is intentional
+ local dest=/usr/share/doc/qt-${PV%%_p*}
+ insinto "${dest}"
+ doins -r *
+ docompress -x "${dest}"
+
+ # these files are not shipped in any other version of qt-docs and collide with qtcore
+ # bug 597026
+ rm -r "${ED}"/usr/share/doc/qt-5.6.2/global
+}