summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-06-12 05:09:33 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-06-12 06:22:05 +0300
commit51e8cb98f7afb5be29c55521a621634c99370d5f (patch)
treeafb697d77511b785c734027a148f2e512b430fd5
parent7aa417bec3fd95bd96b1b409aa3439138abb7396 (diff)
downloadgentoo-51e8cb98f7afb5be29c55521a621634c99370d5f.tar.gz
gentoo-51e8cb98f7afb5be29c55521a621634c99370d5f.tar.xz
dev-libs/opencryptoki: cleanup
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/opencryptoki/Manifest1
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.3.ebuild102
2 files changed, 0 insertions, 103 deletions
diff --git a/dev-libs/opencryptoki/Manifest b/dev-libs/opencryptoki/Manifest
index 48052ae282a..3cbb424bfea 100644
--- a/dev-libs/opencryptoki/Manifest
+++ b/dev-libs/opencryptoki/Manifest
@@ -1,2 +1 @@
-DIST opencryptoki-v3.3.tgz 937619 SHA256 e1deac5edd571621dc1624e9b7af8d1632d6db6f18815f5ed8824fc78f354609 SHA512 53efbc6009da178473abf17d092249781b1eb465f68c83653bd5e88703b9ad74ce9e0128486dffec65beaf8b8974ea6852d206ec5bf035c7296a40c8f84791ab WHIRLPOOL d939eb97bb7f2b54d510326ac4dba4dc49f9f725fa8900687fd8ebe199ce1c2a797a6e514378995f24ef5b9e904b29434edf962537dc545c2fc2206d180b1d43
DIST opencryptoki-v3.4.1.tgz 1014416 SHA256 018ea402f3a1b38b203282fb047dfac209d94bf2988f2c29793eca65455452c4 SHA512 98643463102f70226255f17a7c49cc454cce377404155b9624e77e36c9f03fb30c216d1769177666489a539e0886b071103a089c565f8fbf120c2a53239a2dd6 WHIRLPOOL c05b61c220e87af361cf67c5223f5745e305c5039a610bb740d2e729299517363d5d7d03175869ab517519857a526ac0272f1556bd9e1cd9dea84bd500595f7e
diff --git a/dev-libs/opencryptoki/opencryptoki-3.3.ebuild b/dev-libs/opencryptoki/opencryptoki-3.3.ebuild
deleted file mode 100644
index 48dbad59493..00000000000
--- a/dev-libs/opencryptoki/opencryptoki-3.3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit autotools multilib flag-o-matic user
-
-DESCRIPTION="PKCS#11 provider cryptographic hardware"
-HOMEPAGE="http://sourceforge.net/projects/opencryptoki"
-SRC_URI="mirror://sourceforge/opencryptoki/${PV}/${PN}-v${PV}.tgz"
-
-# Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
-# token sources are under CPL-1.0 already.
-LICENSE="CPL-0.5"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-RDEPEND="tpm? ( app-crypt/trousers )
- dev-libs/openssl:*"
-DEPEND="${RDEPEND}"
-
-IUSE="+tpm debug"
-
-S="${WORKDIR}/${PN}"
-
-# tests right now basically don't exist; the only available thing would
-# test against an installed copy and would kill a running pcscd, all
-# things that we're not interested to.
-RESTRICT=test
-
-pkg_setup() {
- enewgroup pkcs11
-}
-
-src_prepare() {
- mv configure.in configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- # package uses ${localstatedir}/lib as the default path, so if we
- # leave it to econf, it'll create /var/lib/lib.
-
- # Since upstream by default seem to enable any possible token, even
- # when they don't seem to be used, we limit ourselves to the
- # software emulation token (swtok) and if the user enabled the tpm
- # USE flag, tpmtok. The rest of the tokens seem to be hardware- or
- # software-dependent even when they build fine without their
- # requirements, but until somebody asks for those, I'd rather not
- # enable them.
-
- # We don't use --enable-debug because that tinkers with the CFLAGS
- # and we don't want that. Instead we append -DDEBUG which enables
- # debug information.
- use debug && append-flags -DDEBUG
-
- econf \
- --localstatedir=/var \
- --enable-fast-install \
- --disable-dependency-tracking \
- --disable-debug \
- --enable-daemon \
- --enable-library \
- --disable-icatok \
- --enable-swtok \
- $(use_enable tpm tpmtok) \
- --disable-ccatok \
- --disable-pkcscca_migrate
-}
-
-src_install() {
- emake install DESTDIR="${ED}"
-
- # Install libopencryptoki in the standard directory for libraries.
- mv "${D}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${D}"/usr/$(get_libdir) || die
- rm "${D}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
- dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
-
- # Remove compatibility symlinks as we _never_ required those and
- # they seem unused even upstream.
- find "${D}" -name 'PKCS11_*' -delete
-
- # doesn't use libltdl; only dlopen()-based interfaces
- find "${D}" -name '*.la' -delete
-
- # We replace their ld.so and init files (mostly designed for RedHat
- # as far as I can tell) with our own replacements.
- rm -rf "${D}"/etc/ld.so.conf.d "${D}"/etc/rc.d
-
- # make sure that we don't modify the init script if the USE flags
- # are enabled for the needed services.
- cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init
- use tpm || sed -i -e '/use tcsd/d' "${T}"/pkcsslotd.init
- newinitd "${T}/pkcsslotd.init" pkcsslotd
-
- # We create /var dirs at runtime as needed, so don't bother installing
- # our own.
- rm -r "${D}"/var/{lib,lock} || die
-
- dodoc README AUTHORS FAQ TODO doc/openCryptoki-HOWTO.pdf
-}