summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-21 01:40:56 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-03-21 01:40:56 +0100
commit52ff8a40e4275e0b68a59df3c7c0305fe2dabe36 (patch)
treefd5a68bb49763fb6fb394a27b5e70bb67f84dcf1
parent7434744ad7d53d26463c1e4d42cc123a5ec5fae6 (diff)
downloadgentoo-52ff8a40e4275e0b68a59df3c7c0305fe2dabe36.tar.gz
gentoo-52ff8a40e4275e0b68a59df3c7c0305fe2dabe36.tar.xz
sys-fs/owfs: Fix sub slot
Package-Manager: Portage-2.3.24, Repoman-2.3.6 RepoMan-Options: --force
-rw-r--r--sys-fs/owfs/owfs-3.1_p4-r1.ebuild (renamed from sys-fs/owfs/owfs-3.1_p4.ebuild)9
-rw-r--r--sys-fs/owfs/owfs-3.2_p2-r1.ebuild (renamed from sys-fs/owfs/owfs-3.2_p2.ebuild)7
2 files changed, 9 insertions, 7 deletions
diff --git a/sys-fs/owfs/owfs-3.1_p4.ebuild b/sys-fs/owfs/owfs-3.1_p4-r1.ebuild
index 50af8d0e122..493fd92843b 100644
--- a/sys-fs/owfs/owfs-3.1_p4.ebuild
+++ b/sys-fs/owfs/owfs-3.1_p4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 eutils linux-info perl-functions systemd user
+inherit autotools distutils-r1 eutils linux-info perl-functions systemd user versionator
MY_P=${P/_/}
@@ -15,12 +15,13 @@ SRC_URI="mirror://sourceforge/owfs/${MY_P}.tar.gz"
HOMEPAGE="http://owfs.org/ https://sourceforge.net/projects/owfs/"
KEYWORDS="amd64 arm x86"
-SLOT="0/4.0.0"
+# Upstream uses crazy SONAME, https://github.com/owfs/owfs/commit/c696fa9b9b44f49c96b9f1c2b3159d277e0c1273
+SLOT="0/${PV}"
LICENSE="GPL-2"
RDEPEND="
ftdi? ( dev-embedded/libftdi:0 )
- fuse? ( sys-fs/fuse )
+ fuse? ( sys-fs/fuse:0= )
perl? ( dev-lang/perl:= )
parport? ( sys-kernel/linux-headers )
php? ( dev-lang/php:=[cli] )
diff --git a/sys-fs/owfs/owfs-3.2_p2.ebuild b/sys-fs/owfs/owfs-3.2_p2-r1.ebuild
index b8e17902bbb..c30388eef07 100644
--- a/sys-fs/owfs/owfs-3.2_p2.ebuild
+++ b/sys-fs/owfs/owfs-3.2_p2-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python2_7 )
DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 ltprune linux-info perl-functions systemd user
+inherit autotools distutils-r1 ltprune linux-info perl-functions systemd user versionator
MY_P=${P/_/}
@@ -15,12 +15,13 @@ SRC_URI="mirror://sourceforge/owfs/${MY_P}.tar.gz"
HOMEPAGE="http://owfs.org/ https://sourceforge.net/projects/owfs/"
KEYWORDS="~amd64 ~arm ~x86"
-SLOT="0/4.0.0"
+# Upstream uses crazy SONAME, https://github.com/owfs/owfs/commit/c696fa9b9b44f49c96b9f1c2b3159d277e0c1273
+SLOT="0/${PV}"
LICENSE="GPL-2"
RDEPEND="
ftdi? ( dev-embedded/libftdi:0 )
- fuse? ( sys-fs/fuse:0 )
+ fuse? ( sys-fs/fuse:0= )
perl? ( dev-lang/perl:= )
parport? ( sys-kernel/linux-headers )
php? ( dev-lang/php:=[cli] )