summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-10 22:00:50 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commit535a199805fff10b83fc2b2842ce0150170fa0c1 (patch)
treebffcc0f1ea9062c72f213822726d55205f2ff6e9
parent518826587ce6991b4bbe3b1a666c0b519e5af662 (diff)
downloadgentoo-535a199805fff10b83fc2b2842ce0150170fa0c1.tar.gz
gentoo-535a199805fff10b83fc2b2842ce0150170fa0c1.tar.xz
dev-haskell/shelly: bump up to 1.6.6
Package-Manager: portage-2.2.28
-rw-r--r--dev-haskell/shelly/Manifest1
-rw-r--r--dev-haskell/shelly/files/shelly-1.6.5-ghc-8.patch16
-rw-r--r--dev-haskell/shelly/shelly-1.6.6.ebuild54
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/shelly/Manifest b/dev-haskell/shelly/Manifest
index 8c0b320c4e8..e749495989b 100644
--- a/dev-haskell/shelly/Manifest
+++ b/dev-haskell/shelly/Manifest
@@ -1,2 +1,3 @@
DIST shelly-1.5.6.tar.gz 28264 SHA256 f45f778d21661f616cfc849f7729e5aecef7250687e5b30c12e6d8118706d6ee SHA512 522aa76454211b9f31dc92f052703e3f9f4a103c134da063ff5c4c04e209a1f881dc10c0f8589c557ad179a8dc319951b897b8ff401dd8f9a371f69f1def6022 WHIRLPOOL 25455d9800acb5303910bab4d0d91567b3fafc74d614a2875772a60cc594213d572a92cdb46e06030f5584796e1c7ff91aaf3042c79cbcddd9c9de6a39ecf076
DIST shelly-1.6.5.tar.gz 97274 SHA256 bdfd09b01f3de8e7e58e98591ab1a42ad5a74308ff29f19acd16d7cc85b71cdc SHA512 6a5b418987392d755e7faf60206a3e9283e98f56a4d9d9f956c0385074ff8909fb6bddceb050b00dbd0f8eda55eeb4897d9afd2f8dd2d510367567336a7a6770 WHIRLPOOL 127f28061a33f979a884b1e110bcb4aabc10e7cf6eae9953e0fbce0bb842e8022574955c7a8ff4a5d411ee088aedcf76c08eff768aa743f6e56f22da0f4606f2
+DIST shelly-1.6.6.tar.gz 97529 SHA256 9c89e1ed25de9ede0ee6d6a4094ff72ca6af5b1a1f67503ea40a87beb796e1c5 SHA512 1b78cb84d126f6bb67db3a3d5e669759e71811e2770831af41a4867d094f89b32c3cf39363cc39c808e71019d6e7eca18d25e854bbf4160bd3388c6769a8665c WHIRLPOOL 7a160e8cb20c88cc6e6304cfc704bd037fa689f4748bf51cde7e5f54f4267cd4b7428922f2da8219efdf084c43dcc66b270054e2b3313cc5a3ea417db2416a04
diff --git a/dev-haskell/shelly/files/shelly-1.6.5-ghc-8.patch b/dev-haskell/shelly/files/shelly-1.6.5-ghc-8.patch
new file mode 100644
index 00000000000..75d56220e38
--- /dev/null
+++ b/dev-haskell/shelly/files/shelly-1.6.5-ghc-8.patch
@@ -0,0 +1,16 @@
+diff --git a/src/Shelly/Lifted.hs b/src/Shelly/Lifted.hs
+index 825201d..cdca61b 100644
+--- a/src/Shelly/Lifted.hs
++++ b/src/Shelly/Lifted.hs
+@@ -2,4 +2,4 @@
+ FlexibleInstances, FlexibleContexts, IncoherentInstances,
+- TypeFamilies, ExistentialQuantification, RankNTypes,
+- ImpredicativeTypes #-}
++ TypeFamilies, ExistentialQuantification, RankNTypes
++ #-}
+ {-# OPTIONS_GHC -fno-warn-orphans #-}
+@@ -299,3 +299,3 @@ instance (MonadShControl m, Monoid w)
+ controlSh :: MonadShControl m => ((forall x. m x -> Sh (ShM m x)) -> Sh (ShM m a)) -> m a
+-controlSh = liftShWith >=> restoreSh
++controlSh r = liftShWith r >>= restoreSh
+ {-# INLINE controlSh #-}
diff --git a/dev-haskell/shelly/shelly-1.6.6.ebuild b/dev-haskell/shelly/shelly-1.6.6.ebuild
new file mode 100644
index 00000000000..eed04c82c7e
--- /dev/null
+++ b/dev-haskell/shelly/shelly-1.6.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="shell-like (systems) programming in Haskell"
+HOMEPAGE="https://github.com/yesodweb/Shelly.hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="lifted"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ dev-haskell/enclosed-exceptions:=[profile?]
+ >=dev-haskell/exceptions-0.6:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ dev-haskell/lifted-async:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/monad-control-0.3.2:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ <dev-haskell/system-fileio-0.4:=[profile?]
+ >=dev-haskell/system-filepath-0.4.7:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.5
+ >=dev-haskell/hunit-1.2
+ >=dev-haskell/text-0.11 )
+"
+
+PATCHES=("${FILESDIR}"/${PN}-1.6.5-ghc-8.patch)
+
+src_prepare() {
+ cabal_chdeps \
+ 'time >= 1.3 && < 1.6' 'time >= 1.3'
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag lifted lifted)
+}