summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-02-19 01:33:51 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-02-19 02:23:23 +0100
commit67fb3694a54ab1c8a19fdf16d5b0421aa982e0e0 (patch)
tree84c4b11f9e0b93b9e6a221162b79e584e6637564
parent0f6058d83df96f2ca063fb07195f34bf6f9f3d60 (diff)
downloadgentoo-67fb3694a54ab1c8a19fdf16d5b0421aa982e0e0.tar.gz
gentoo-67fb3694a54ab1c8a19fdf16d5b0421aa982e0e0.tar.xz
dev-lang/rust: doesn't support >=sys-devel/llvm-8
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.30.1-r1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.31.1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.32.0.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/dev-lang/rust/rust-1.30.1-r1.ebuild b/dev-lang/rust/rust-1.30.1-r1.ebuild
index f0ff75335fa..7aee61f2377 100644
--- a/dev-lang/rust/rust-1.30.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.30.1-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+LLVM_MAX_SLOT=7
+
inherit check-reqs eapi7-ver estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
if [[ ${PV} = *beta* ]]; then
@@ -182,7 +184,7 @@ src_configure() {
EOF
if use system-llvm; then
cat <<- EOF >> "${S}"/config.toml
- llvm-config = "$(get_llvm_prefix)/bin/llvm-config"
+ llvm-config = "$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
EOF
fi
done
diff --git a/dev-lang/rust/rust-1.31.1.ebuild b/dev-lang/rust/rust-1.31.1.ebuild
index 22ed3b4a4c0..debbd8a7a98 100644
--- a/dev-lang/rust/rust-1.31.1.ebuild
+++ b/dev-lang/rust/rust-1.31.1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+LLVM_MAX_SLOT=7
+
inherit check-reqs eapi7-ver estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
if [[ ${PV} = *beta* ]]; then
@@ -182,7 +184,7 @@ src_configure() {
EOF
if use system-llvm; then
cat <<- EOF >> "${S}"/config.toml
- llvm-config = "$(get_llvm_prefix)/bin/llvm-config"
+ llvm-config = "$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
EOF
fi
done
diff --git a/dev-lang/rust/rust-1.32.0.ebuild b/dev-lang/rust/rust-1.32.0.ebuild
index bc2a6106b8a..18425b87101 100644
--- a/dev-lang/rust/rust-1.32.0.ebuild
+++ b/dev-lang/rust/rust-1.32.0.ebuild
@@ -5,6 +5,8 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+LLVM_MAX_SLOT=7
+
inherit check-reqs eapi7-ver estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
if [[ ${PV} = *beta* ]]; then
@@ -45,7 +47,7 @@ COMMON_DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
net-libs/libssh2
net-libs/http-parser:=
net-misc/curl[ssl]
- system-llvm? ( >=sys-devel/llvm-7:= )"
+ system-llvm? ( sys-devel/llvm:7= )"
DEPEND="${COMMON_DEPEND}
${PYTHON_DEPS}
|| (
@@ -184,7 +186,7 @@ src_configure() {
EOF
if use system-llvm; then
cat <<- EOF >> "${S}"/config.toml
- llvm-config = "$(get_llvm_prefix)/bin/llvm-config"
+ llvm-config = "$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
EOF
fi
done