summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-28 17:28:27 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-28 17:28:44 +0000
commit6806b0dac0cbda1f0c55f9f1c0600dbe48945cd0 (patch)
tree4b9ab676ec991aafe6a44387527134c35e3a61d1
parent32d5f3bb31dff83568c306063aabc06efd063dc7 (diff)
parente69eb361dd801b36aee57ca1f9c82ded705cafa2 (diff)
downloadgentoo-6806b0dac0cbda1f0c55f9f1c0600dbe48945cd0.tar.gz
gentoo-6806b0dac0cbda1f0c55f9f1c0600dbe48945cd0.tar.xz
Merge remote-tracking branch 'github/pr/413'.
-rw-r--r--app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.1.0-r1.ebuild48
-rw-r--r--app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild48
-rw-r--r--app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.3.0-r1.ebuild50
3 files changed, 146 insertions, 0 deletions
diff --git a/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.1.0-r1.ebuild b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.1.0-r1.ebuild
new file mode 100644
index 00000000000..e016c7669fb
--- /dev/null
+++ b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross platform personalization tool for the YubiKey NEO"
+HOMEPAGE="https://developers.yubico.com/yubikey-neo-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ app-crypt/libu2f-host
+ app-crypt/libykneomgr
+ sys-auth/ykpers"
+
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
+
+DOCS=( NEWS README )
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman scripts/neoman.1
+ domenu resources/neoman.desktop
+ doicon resources/neoman.xpm
+ newicon -s 128 resources/neoman-large.png neoman.png
+}
diff --git a/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild
new file mode 100644
index 00000000000..e016c7669fb
--- /dev/null
+++ b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.2.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross platform personalization tool for the YubiKey NEO"
+HOMEPAGE="https://developers.yubico.com/yubikey-neo-manager/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ app-crypt/libu2f-host
+ app-crypt/libykneomgr
+ sys-auth/ykpers"
+
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
+
+DOCS=( NEWS README )
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman scripts/neoman.1
+ domenu resources/neoman.desktop
+ doicon resources/neoman.xpm
+ newicon -s 128 resources/neoman-large.png neoman.png
+}
diff --git a/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.3.0-r1.ebuild b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.3.0-r1.ebuild
new file mode 100644
index 00000000000..1d63d9e2c4b
--- /dev/null
+++ b/app-crypt/yubikey-neo-manager/yubikey-neo-manager-1.3.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross platform personalization tool for the YubiKey NEO"
+HOMEPAGE="https://developers.yubico.com/yubikey-neo-manager/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+CDEPEND="
+ dev-python/pyside[webkit,${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ app-crypt/libu2f-host
+ app-crypt/libykneomgr
+ sys-auth/ykpers"
+
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+
+RDEPEND="${CDEPEND}"
+
+DOCS=( NEWS README )
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman scripts/neoman.1
+ domenu resources/neoman.desktop
+ doicon resources/neoman.xpm
+ newicon -s 128 resources/neoman-large.png neoman.png
+}