summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-21 10:49:52 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-21 10:56:20 +0200
commit695ad4fe3cf7ec91d85be2500c22d1dc2a3a63de (patch)
treefcbd8b8012405923b58620d77e0017395d86cb16
parent140aa82ec260d06b93c9d169de688251b2110b2d (diff)
downloadgentoo-695ad4fe3cf7ec91d85be2500c22d1dc2a3a63de.tar.gz
gentoo-695ad4fe3cf7ec91d85be2500c22d1dc2a3a63de.tar.xz
dev-util/squashdelta: Modernize the live ebuild, EAPI=6
-rw-r--r--dev-util/squashdelta/squashdelta-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/dev-util/squashdelta/squashdelta-9999.ebuild b/dev-util/squashdelta/squashdelta-9999.ebuild
index f0193e21d63..fd19fe30514 100644
--- a/dev-util/squashdelta/squashdelta-9999.ebuild
+++ b/dev-util/squashdelta/squashdelta-9999.ebuild
@@ -1,32 +1,21 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils
+inherit autotools git-r3
DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
HOMEPAGE="https://github.com/mgorny/squashdelta/"
-SRC_URI="https://www.github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+SRC_URI=""
# uses public-domain murmurhash3
LICENSE="BSD public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="lz4 +lzo"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-#endif
-
COMMON_DEPEND="
lz4? ( app-arch/lz4:0= )
lzo? ( dev-libs/lzo:2= )"
@@ -37,11 +26,16 @@ DEPEND=${COMMON_DEPEND}
# SquashDelta does not make much sense without a compression algo.
REQUIRED_USE="|| ( lz4 lzo )"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
- local myeconfargs=(
+ local myconf=(
$(use_enable lz4)
$(use_enable lzo)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}