summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-31 00:18:13 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-31 00:20:17 +0800
commit728ab577c5f533cbd9fe65585e35b28c896189bf (patch)
treed8d09432c7384d7347edcbb7c04dfd1ea76184a4
parenta62079ddda10039b692df7a77fb4ec572027b2e5 (diff)
parent2cd49f7b13c5eb393428bc32f9f615ffafa99821 (diff)
downloadgentoo-728ab577c5f533cbd9fe65585e35b28c896189bf.tar.gz
gentoo-728ab577c5f533cbd9fe65585e35b28c896189bf.tar.xz
Merge remote-tracking branch 'remotes/sbraz/pyenchant'
Pull request: https://github.com/gentoo/gentoo/pull/742
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.6.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/pyenchant/pyenchant-1.6.6.ebuild b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
index aee6148939c..9d92fa22817 100644
--- a/dev-python/pyenchant/pyenchant-1.6.6.ebuild
+++ b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
inherit distutils-r1
@@ -15,12 +15,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
-IUSE=""
+IUSE="test"
-DEPEND="
- >=app-text/enchant-${PV%.*}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND=">=app-text/enchant-${PV%.*}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
python_test() {
if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then