summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-07-25 16:11:27 -0400
committerCraig Andrews <candrews@gentoo.org>2018-07-25 16:12:05 -0400
commit72f5117ddd60938a68ca560784f56be683acbcc6 (patch)
treefbca06d0cfed238c10a1eacb2b1b17c8a68d5a31
parent0fbd3db01ff441c2286835555f3a039ea23a1057 (diff)
downloadgentoo-72f5117ddd60938a68ca560784f56be683acbcc6.tar.gz
gentoo-72f5117ddd60938a68ca560784f56be683acbcc6.tar.xz
dev-libs/libfstrcmp: eautoreconf and add DOC use flag
Closes: https://bugs.gentoo.org/662128 Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild b/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
index c156bb325b5..f4d6bb2c005 100644
--- a/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
+++ b/dev-libs/libfstrcmp/libfstrcmp-0.7.ebuild
@@ -3,13 +3,35 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="Make fuzzy comparisons of strings and byte arrays"
HOMEPAGE="http://fstrcmp.sourceforge.net/"
LICENSE="GPL-3+"
-IUSE="test"
+IUSE="doc test"
SLOT="0"
SRC_URI="http://fstrcmp.sourceforge.net/fstrcmp-0.7.D001.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/fstrcmp-0.7.D001"
KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ doc? ( app-text/ghostscript-gpl )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake all-bin
+ use doc && emake all-doc
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-bin install-include install-libdir install-man
+ use doc && emake DESTDIR="${D}" install-doc
+ einstalldocs
+}