summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-30 16:11:14 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-30 16:11:26 +0100
commit76aca9c8583227c0a267442b3f82d162b101dfea (patch)
tree4c6a783039f083bafd58323314f03a7886a1ee0b
parent5d7854fa7659e6281bb9c159f06c490f5e6a1d55 (diff)
downloadgentoo-76aca9c8583227c0a267442b3f82d162b101dfea.tar.gz
gentoo-76aca9c8583227c0a267442b3f82d162b101dfea.tar.xz
sys-fs/bcache-tools: Fix build problems
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573372 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220-r1.ebuild (renamed from sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220.ebuild b/sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220-r1.ebuild
index a3a949e12ab..af47111be78 100644
--- a/sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220.ebuild
+++ b/sys-fs/bcache-tools/bcache-tools-1.0.8_p20140220-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python3_{3,4,5} )
-inherit eutils python-r1 toolchain-funcs udev
+inherit eutils flag-o-matic python-r1 toolchain-funcs udev
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="http://bcache.evilpiepirate.org/"
@@ -32,7 +32,6 @@ PATCHES=(
"${FILESDIR}"/${PV}/bcache-tools-1.0.8-noprobe.patch
"${FILESDIR}"/${PV}/bcache-tools-20131018-fedconf.patch
"${FILESDIR}"/${PV}/bcache-tools-status-20130826-man.patch
- "${FILESDIR}"/${PV}/bcache-tools-1.0.8-probe-bcache-underlinking.patch
)
S="${WORKDIR}"/${P%%_p*}
@@ -41,9 +40,11 @@ src_prepare() {
tc-export CC
sed \
-e '/^CFLAGS/s:-O2::' \
- -e '/^CFLAGS/s:-g::' \
+ -e '/^CFLAGS/s:-g:-std=gnu99:' \
-i Makefile || die
+ append-lfs-flags
+
cp ../bcache-status*/bcache-status . || die
epatch "${PATCHES[@]}"