summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-12 06:45:32 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-12 06:45:32 +0200
commit7a8d3da0200ea81335eb0460b67f99a6d8d954da (patch)
tree4e1102f8b3ba45945b806b43fd516a207b35f077
parent182164619123e94896d374c76c6766083973916b (diff)
downloadgentoo-7a8d3da0200ea81335eb0460b67f99a6d8d954da.tar.gz
gentoo-7a8d3da0200ea81335eb0460b67f99a6d8d954da.tar.xz
dev-ruby/amq-protocol: add 2.0.1-r1
Add ruby23. Drop x86 keyword due to bug 562452 Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.0.1-r1.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.0.1-r1.ebuild
new file mode 100644
index 00000000000..b0c6aa80e22
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}