summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-10-19 22:51:44 -0400
committerMike Gilbert <floppym@gentoo.org>2015-10-19 23:09:33 -0400
commit7db32bc8ba0e8f455c6a3222f6926299012674e9 (patch)
tree95bb3db905c26f805b8230d74c9c86a569094780
parentb13815a11545ddf9d5ef1db942ad7aea1d8c58c3 (diff)
downloadgentoo-7db32bc8ba0e8f455c6a3222f6926299012674e9.tar.gz
gentoo-7db32bc8ba0e8f455c6a3222f6926299012674e9.tar.xz
dev-python/packaging: Force setup.py to use distutils
Bug: https://bugs.gentoo.org/563534 Package-Manager: portage-2.2.23_p4
-rw-r--r--dev-python/packaging/files/packaging-15.3-distutils.patch (renamed from dev-python/packaging/files/packaging-15.3-setuptools.patch)18
-rw-r--r--dev-python/packaging/packaging-15.3-r2.ebuild (renamed from dev-python/packaging/packaging-15.3-r1.ebuild)15
-rw-r--r--dev-python/packaging/packaging-15.3.ebuild31
3 files changed, 20 insertions, 44 deletions
diff --git a/dev-python/packaging/files/packaging-15.3-setuptools.patch b/dev-python/packaging/files/packaging-15.3-distutils.patch
index abb0662cc56..bd3b8ccebe9 100644
--- a/dev-python/packaging/files/packaging-15.3-setuptools.patch
+++ b/dev-python/packaging/files/packaging-15.3-distutils.patch
@@ -1,25 +1,19 @@
- setup.py | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
+Force setup.py to use distutils
+
+Bug: https://bugs.gentoo.org/563534
-diff --git a/setup.py b/setup.py
-index 13c9dad..9d68590 100644
--- a/setup.py
+++ b/setup.py
-@@ -15,7 +15,12 @@
+@@ -15,7 +15,7 @@
from __future__ import absolute_import, division, print_function
import os
-import setuptools
-+
-+try:
-+ from setuptools import setup
-+except ImportError:
-+ from distutils.core import setup
-+
++from distutils.core import setup
base_dir = os.path.dirname(__file__)
-@@ -31,7 +36,7 @@ with open(os.path.join(base_dir, "CHANGELOG.rst")) as f:
+@@ -31,7 +31,7 @@ with open(os.path.join(base_dir, "CHANGELOG.rst")) as f:
long_description = "\n".join([long_description, f.read()])
diff --git a/dev-python/packaging/packaging-15.3-r1.ebuild b/dev-python/packaging/packaging-15.3-r2.ebuild
index bd92da65a30..ae34a310764 100644
--- a/dev-python/packaging/packaging-15.3-r1.ebuild
+++ b/dev-python/packaging/packaging-15.3-r2.ebuild
@@ -25,8 +25,21 @@ DEPEND="${RDEPEND}
)
"
-PATCHES=( "${FILESDIR}"/${P}-setuptools.patch )
+PATCHES=( "${FILESDIR}"/${P}-distutils.patch )
python_test() {
py.test --capture=no --strict -v || die
}
+
+pkg_preinst() {
+ # Remove this in the next version bump
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}
diff --git a/dev-python/packaging/packaging-15.3.ebuild b/dev-python/packaging/packaging-15.3.ebuild
deleted file mode 100644
index 31c92c1e30d..00000000000
--- a/dev-python/packaging/packaging-15.3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test --capture=no --strict -v || die
-}