summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-30 18:39:17 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-30 19:47:43 -0400
commit86fa1657a0722f6e1179e3d6f1e94a6d6b6995fb (patch)
tree949837aa4bcc78c9314f9ebb7e5736b6bf76a033
parent2de9f8273b9e29bba38c2a613433bd5ff50ec00f (diff)
downloadgentoo-86fa1657a0722f6e1179e3d6f1e94a6d6b6995fb.tar.gz
gentoo-86fa1657a0722f6e1179e3d6f1e94a6d6b6995fb.tar.xz
app-arch/bzip2: drop old <1.0.6-r6 versions
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r1.ebuild73
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r2.ebuild73
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r3.ebuild80
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r4.ebuild87
-rw-r--r--app-arch/bzip2/bzip2-1.0.6.ebuild68
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-progress.patch175
6 files changed, 0 insertions, 556 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.6-r1.ebuild b/app-arch/bzip2/bzip2-1.0.6-r1.ebuild
deleted file mode 100644
index 8f48338af66..00000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@" || die
-}
-src_compile() {
- bemake -f Makefile-libbz2_so all || die
- use static && append-flags -static
- bemake all || die
-}
-
-src_install() {
- emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
- dodoc README* CHANGES bzip2.txt manual.*
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV} || die
- local s
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v} || die
- done
- gen_usr_ldscript -a bz2
-
- if ! use static ; then
- newbin bzip2-shared bzip2 || die
- fi
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dodir /bin
- mv "${D}"/usr/bin/b{zip2,zcat,unzip2} "${D}"/bin/ || die
- dosym bzip2 /bin/bzcat || die
- dosym bzip2 /bin/bunzip2 || die
-}
diff --git a/app-arch/bzip2/bzip2-1.0.6-r2.ebuild b/app-arch/bzip2/bzip2-1.0.6-r2.ebuild
deleted file mode 100644
index 734eea8b3b9..00000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="static"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.6-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@" || die
-}
-src_compile() {
- bemake -f Makefile-libbz2_so all || die
- use static && append-flags -static
- bemake all || die
-}
-
-src_install() {
- emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
- dodoc README* CHANGES bzip2.txt manual.*
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV} || die
- local s
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v} || die
- done
- gen_usr_ldscript -a bz2
-
- if ! use static ; then
- newbin bzip2-shared bzip2 || die
- fi
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dodir /bin
- mv "${D}"/usr/bin/b{zip2,zcat,unzip2} "${D}"/bin/ || die
- dosym bzip2 /bin/bzcat || die
- dosym bzip2 /bin/bunzip2 || die
-}
diff --git a/app-arch/bzip2/bzip2-1.0.6-r3.ebuild b/app-arch/bzip2/bzip2-1.0.6-r3.ebuild
deleted file mode 100644
index 8018d7a4379..00000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI="2"
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="static static-libs"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.6-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- epatch "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@" || die
-}
-src_compile() {
- bemake -f Makefile-libbz2_so all || die
- use static && append-flags -static
- bemake all || die
-}
-
-src_install() {
- emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
- dodoc README* CHANGES bzip2.txt manual.*
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV} || die
- local s
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v} || die
- done
- gen_usr_ldscript -a bz2
-
- if ! use static ; then
- newbin bzip2-shared bzip2 || die
- fi
- if ! use static-libs ; then
- rm -f "${D}"/usr/lib*/libbz2.a || die
- fi
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dodir /bin
- mv "${D}"/usr/bin/b{zip2,zcat,unzip2} "${D}"/bin/ || die
- dosym bzip2 /bin/bzcat || die
- dosym bzip2 /bin/bunzip2 || die
-}
diff --git a/app-arch/bzip2/bzip2-1.0.6-r4.ebuild b/app-arch/bzip2/bzip2-1.0.6-r4.ebuild
deleted file mode 100644
index dd02be68e78..00000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI=4
-
-inherit eutils toolchain-funcs multilib multilib-minimal
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="static static-libs"
-
-RDEPEND="abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20130224
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.6-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- epatch "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s -f :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-
- multilib_copy_sources
-}
-
-bemake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@"
-}
-
-multilib_src_compile() {
- bemake -f Makefile-libbz2_so all
- bemake all LDFLAGS="${LDFLAGS} $(usex static -static '')"
-}
-
-multilib_src_install() {
- emake PREFIX="${ED}"/usr LIBDIR=$(get_libdir) install
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV}
- local v
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v}
- done
- gen_usr_ldscript -a bz2
-
- use static || newbin bzip2-shared bzip2
-}
-
-multilib_src_install_all() {
- dodoc README* CHANGES bzip2.txt manual.*
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dodir /bin
- mv "${ED}"/usr/bin/b{zip2,zcat,unzip2} "${ED}"/bin/ || die
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-
- use static-libs || find "${ED}"/usr -name libbz2.a -delete
-}
diff --git a/app-arch/bzip2/bzip2-1.0.6.ebuild b/app-arch/bzip2/bzip2-1.0.6.ebuild
deleted file mode 100644
index fa6a1278370..00000000000
--- a/app-arch/bzip2/bzip2-1.0.6.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@" || die
-}
-src_compile() {
- bemake -f Makefile-libbz2_so all || die
- use static && append-flags -static
- bemake all || die
-}
-
-src_install() {
- emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
- dodoc README* CHANGES bzip2.txt manual.*
-
- # Install the shared lib manually
- dolib.so libbz2.so.${PV} || die
- dosym libbz2.so.${PV} /usr/$(get_libdir)/libbz2.so || die
- dosym libbz2.so.${PV} /usr/$(get_libdir)/libbz2.so.${PV%%.*} || die
- gen_usr_ldscript -a bz2
-
- if ! use static ; then
- newbin bzip2-shared bzip2 || die
- fi
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dodir /bin
- mv "${D}"/usr/bin/b{zip2,zcat,unzip2} "${D}"/bin/ || die
- dosym bzip2 /bin/bzcat || die
- dosym bzip2 /bin/bunzip2 || die
-}
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-progress.patch b/app-arch/bzip2/files/bzip2-1.0.2-progress.patch
deleted file mode 100644
index 2f389cfac98..00000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-progress.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-Ripped from Mandrake.
-
-http://bugs.gentoo.org/show_bug.cgi?id=82192
-
---- bzip2-1.0.2.org/bzip2.1
-+++ bzip2-1.0.2/bzip2.1
-@@ -235,6 +235,10 @@
- Suppress non-essential warning messages. Messages pertaining to
- I/O errors and other critical events will not be suppressed.
- .TP
-+.B \-p --show-progress
-+Show percentage of input-file done and while compressing show the percentage
-+of the original file the new file is.
-+.TP
- .B \-v --verbose
- Verbose mode -- show the compression ratio for each file processed.
- Further \-v's increase the verbosity level, spewing out lots of
---- bzip2-1.0.2.org/bzip2.c
-+++ bzip2-1.0.2/bzip2.c
-@@ -145,6 +145,7 @@
- #include <signal.h>
- #include <math.h>
- #include <errno.h>
-+#include <time.h>
- #include <ctype.h>
- #include "bzlib.h"
-
-@@ -301,6 +302,7 @@
- Char progNameReally[FILE_NAME_LEN];
- FILE *outputHandleJustInCase;
- Int32 workFactor;
-+Char showProgress;
-
- static void panic ( Char* ) NORETURN;
- static void ioError ( void ) NORETURN;
-@@ -425,6 +427,12 @@
- UInt32 nbytes_in_lo32, nbytes_in_hi32;
- UInt32 nbytes_out_lo32, nbytes_out_hi32;
- Int32 bzerr, bzerr_dummy, ret;
-+ double fileSize = 0; /* initialized to make the compiler stop crying */
-+ /* double because big files might otherwhise give
-+ * overflows. not long long since not all compilers
-+ * support that one
-+ */
-+ time_t startTime, currentTime;
-
- SET_BINARY_MODE(stream);
- SET_BINARY_MODE(zStream);
-@@ -432,12 +440,21 @@
- if (ferror(stream)) goto errhandler_io;
- if (ferror(zStream)) goto errhandler_io;
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ (void)fseek(stream, 0, SEEK_END);
-+ fileSize = (double)ftell(stream);
-+ rewind(stream);
-+ if (verbosity >= 1)
-+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
-+ }
-+
- bzf = BZ2_bzWriteOpen ( &bzerr, zStream,
- blockSize100k, verbosity, workFactor );
- if (bzerr != BZ_OK) goto errhandler;
-
- if (verbosity >= 2) fprintf ( stderr, "\n" );
-
-+ time(&startTime);
- while (True) {
-
- if (myfeof(stream)) break;
-@@ -446,13 +463,32 @@
- if (nIbuf > 0) BZ2_bzWrite ( &bzerr, bzf, (void*)ibuf, nIbuf );
- if (bzerr != BZ_OK) goto errhandler;
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True)
-+ {
-+ time(&currentTime);
-+
-+ if ((currentTime - startTime) > 1) { /* show progress every 2 seconds */
-+ double curInPos = (double)ftell(stream);
-+ double curOutPos = (double)ftell(zStream);
-+
-+ startTime = currentTime;
-+
-+ fprintf(stderr, "%.2f%% done", (curInPos * 100.0) / fileSize);
-+ if (srcMode == SM_F2F)
-+ {
-+ fprintf(stderr, ", new size: %.2f%%", (curOutPos * 100.0) / curInPos);
-+ }
-+
-+ fprintf(stderr, " \r");
-+ }
-+ }
- }
-
- BZ2_bzWriteClose64 ( &bzerr, bzf, 0,
- &nbytes_in_lo32, &nbytes_in_hi32,
- &nbytes_out_lo32, &nbytes_out_hi32 );
- if (bzerr != BZ_OK) goto errhandler;
--
-+
- if (ferror(zStream)) goto errhandler_io;
- ret = fflush ( zStream );
- if (ret == EOF) goto errhandler_io;
-@@ -526,6 +562,8 @@
- UChar unused[BZ_MAX_UNUSED];
- Int32 nUnused;
- UChar* unusedTmp;
-+ double fileSize = 0; /* initialized to make the compiler stop crying */
-+ time_t startTime, currentTime;
-
- nUnused = 0;
- streamNo = 0;
-@@ -533,9 +571,19 @@
- SET_BINARY_MODE(stream);
- SET_BINARY_MODE(zStream);
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ long dummy = ftell(zStream);
-+ (void)fseek(zStream, 0, SEEK_END);
-+ fileSize = (double)ftell(zStream);
-+ (void)fseek(zStream, dummy, SEEK_SET);
-+ if (verbosity >= 1)
-+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
-+ }
-+
- if (ferror(stream)) goto errhandler_io;
- if (ferror(zStream)) goto errhandler_io;
-
-+ time(&startTime);
- while (True) {
-
- bzf = BZ2_bzReadOpen (
-@@ -551,6 +599,17 @@
- if ((bzerr == BZ_OK || bzerr == BZ_STREAM_END) && nread > 0)
- fwrite ( obuf, sizeof(UChar), nread, stream );
- if (ferror(stream)) goto errhandler_io;
-+
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ time(&currentTime);
-+ if ((currentTime - startTime) >= 2)
-+ {
-+ double curInPos = (double)ftell(zStream);
-+ startTime = currentTime;
-+
-+ fprintf(stderr, "%.2f%% done\r", (curInPos * 100.0) / fileSize);
-+ }
-+ }
- }
- if (bzerr != BZ_STREAM_END) goto errhandler;
-
-@@ -1872,6 +1931,7 @@
- deleteOutputOnInterrupt = False;
- exitValue = 0;
- i = j = 0; /* avoid bogus warning from egcs-1.1.X */
-+ showProgress = False;
-
- /*-- Set up signal handlers for mem access errors --*/
- signal (SIGSEGV, mySIGSEGVorSIGBUScatcher);
-@@ -1949,6 +2009,7 @@
- case 'k': keepInputFiles = True; break;
- case 's': smallMode = True; break;
- case 'q': noisy = False; break;
-+ case 'p': showProgress = True; break;
- case '1': blockSize100k = 1; break;
- case '2': blockSize100k = 2; break;
- case '3': blockSize100k = 3; break;
-@@ -1985,6 +2046,7 @@
- if (ISFLAG("--keep")) keepInputFiles = True; else
- if (ISFLAG("--small")) smallMode = True; else
- if (ISFLAG("--quiet")) noisy = False; else
-+ if (ISFLAG("--show-progress")) showProgress = True; else
- if (ISFLAG("--version")) license(); else
- if (ISFLAG("--license")) license(); else
- if (ISFLAG("--exponential")) workFactor = 1; else