summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-07 12:57:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-07 12:57:27 -0500
commit8dbe82f004070334ab9e77cc3a0198983a2a8a04 (patch)
tree45f2c52d8d7c9398da674d8321226208fc77b166
parent696329499c0f7ae1fdd67d54696e67b2f8d8e9fa (diff)
downloadgentoo-8dbe82f004070334ab9e77cc3a0198983a2a8a04.tar.gz
gentoo-8dbe82f004070334ab9e77cc3a0198983a2a8a04.tar.xz
net-misc/openconnect: adding stoken support to the live ebuild
Package-Manager: portage-2.2.26
-rw-r--r--net-misc/openconnect/openconnect-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-misc/openconnect/openconnect-9999.ebuild b/net-misc/openconnect/openconnect-9999.ebuild
index 403671fa9ad..3a6c716e362 100644
--- a/net-misc/openconnect/openconnect-9999.ebuild
+++ b/net-misc/openconnect/openconnect-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,7 +25,7 @@ HOMEPAGE="http://www.infradead.org/openconnect.html"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0/5"
-IUSE="doc +gnutls gssapi java libressl libproxy nls smartcard static-libs"
+IUSE="doc +gnutls gssapi java libressl libproxy nls smartcard static-libs stoken"
ILINGUAS="ar cs de el en_GB en_US es eu fi fr gl id lt nl pa pl pt pt_BR sk sl tg ug uk zh_CN zh_TW"
for lang in $ILINGUAS; do
IUSE="${IUSE} linguas_${lang}"
@@ -44,7 +44,8 @@ DEPEND="dev-libs/libxml2
gssapi? ( virtual/krb5 )
libproxy? ( net-libs/libproxy )
nls? ( virtual/libintl )
- smartcard? ( sys-apps/pcsc-lite:0= )"
+ smartcard? ( sys-apps/pcsc-lite:0= )
+ stoken? ( app-crypt/stoken )"
RDEPEND="${DEPEND}
sys-apps/iproute2
!<sys-apps/openrc-0.13"
@@ -101,6 +102,7 @@ src_configure() {
--without-stoken \
$(use_with gssapi) \
$(use_with smartcard libpcsclite) \
+ $(use_with stoken) \
$(use_with java)
}