summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-07-13 18:04:58 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-07-13 18:04:58 +0200
commit90c15cc0beda1039c5b27bf33e03dfed3276562c (patch)
tree5e93d7b32ae09488ba618b9df4679cfec701baa0
parentfcfc94349d709fff8645a467873bf19d7bdfe566 (diff)
downloadgentoo-90c15cc0beda1039c5b27bf33e03dfed3276562c.tar.gz
gentoo-90c15cc0beda1039c5b27bf33e03dfed3276562c.tar.xz
x11-wm/stumpwm: Sync with lisp overlay
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--x11-wm/stumpwm/stumpwm-1.0.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild b/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
index 3231eff7bb8..db333dd7696 100644
--- a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
+++ b/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
@@ -40,7 +40,7 @@ get_lisp() {
done
}
-do_doc() {
+install_docs() {
local pdffile="${PN}.pdf"
texi2pdf -o "${pdffile}" "${PN}.texi" && dodoc "${pdffile}" || die
@@ -52,10 +52,6 @@ do_doc() {
src_prepare() {
default
- # Upstream didn't change the version before packaging
- sed -i -e 's/:version "0.9.8"/:version "0.9.9"/' "${PN}.asd" || die
- # Bug 534592. Does not build with asdf:oos, using require to load the package
- sed -i "load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
eautoreconf
}
@@ -74,11 +70,11 @@ src_install() {
make_session_desktop StumpWM /usr/bin/stumpwm
common-lisp-install-sources *.lisp
- common-lisp-install-asdf ${PN}.asd
+ common-lisp-install-asdf
# Fix ASDF dir
sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
"${D}${CLPKGDIR}/load-stumpwm.lisp" || die
- use doc && do_doc
+ use doc && install_docs
}
pkg_postinst() {