summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-02-27 20:29:54 -0800
committerPatrick McLean <chutzpah@gentoo.org>2017-02-27 20:30:23 -0800
commit94b05cdca212da1ed1dccd797a815e9a08fd1aa3 (patch)
tree4f8936f894043ca1315b41e085ed9178658c2294
parente86f553aee4cad122995f3a8a1336156b377c603 (diff)
downloadgentoo-94b05cdca212da1ed1dccd797a815e9a08fd1aa3.tar.gz
gentoo-94b05cdca212da1ed1dccd797a815e9a08fd1aa3.tar.xz
sys-cluster/ceph: Revision bump, fix installation of python modules
For some reason the ceph build system stopped installed required python modules for python2, and only installed them in python3. This fixes the problem so the ceph cli tools will work again. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sys-cluster/ceph/ceph-10.2.5-r3.ebuild (renamed from sys-cluster/ceph/ceph-10.2.5-r2.ebuild)13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-cluster/ceph/ceph-10.2.5-r2.ebuild b/sys-cluster/ceph/ceph-10.2.5-r3.ebuild
index 568216bfa42..cce9b22dd9e 100644
--- a/sys-cluster/ceph/ceph-10.2.5-r2.ebuild
+++ b/sys-cluster/ceph/ceph-10.2.5-r3.ebuild
@@ -135,7 +135,7 @@ user_setup() {
}
emake_python_bindings() {
- local action="${1}" params binding
+ local action="${1}" params binding module
shift
params=("${@}")
@@ -144,8 +144,15 @@ emake_python_bindings() {
emake "${params[@]}" PYTHON="${EPYTHON}" "${binding}-pybind-${action}"
# these don't work and aren't needed on python3
- if [[ ${EBUILD_PHASE} == install ]] && python_is_python3; then
- rm -f "${ED}/$(python_get_sitedir)"/ceph_{argparse,volume_client}.py
+ if [[ ${EBUILD_PHASE} == install ]]; then
+ for module in "${S}"/src/pybind/*.py; do
+ module_basename="$(basename "${module}")"
+ if [[ ${module_basename} == ceph_volume_client.py ]] && ! use cephfs; then
+ continue
+ elif [[ ! -e "${ED}/$(python_get_sitedir)/${module_basename}" ]]; then
+ python_domodule ${module}
+ fi
+ done
fi
}