summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-11 17:33:24 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-11 17:33:44 -0400
commit9b3e9ea46c728eb0aa5ffa19c71f10399969684e (patch)
tree35e3f5a18c09cff1387365f12e5913a200524a49
parent465b88165fe1b39c32347812b43fc5564da90f19 (diff)
downloadgentoo-9b3e9ea46c728eb0aa5ffa19c71f10399969684e.tar.gz
gentoo-9b3e9ea46c728eb0aa5ffa19c71f10399969684e.tar.xz
net-misc/netctl: bump to 1.11
Package-Manager: portage-2.2.28_p64
-rw-r--r--net-misc/netctl/Manifest1
-rw-r--r--net-misc/netctl/netctl-1.11.ebuild67
-rw-r--r--net-misc/netctl/netctl-9999.ebuild2
3 files changed, 69 insertions, 1 deletions
diff --git a/net-misc/netctl/Manifest b/net-misc/netctl/Manifest
index f6205ecb64a..bb3ace8dff2 100644
--- a/net-misc/netctl/Manifest
+++ b/net-misc/netctl/Manifest
@@ -1,2 +1,3 @@
DIST netctl-1.10.tar.xz 43576 SHA256 106cc09f810b7922be8c117129ee739fcd3270c20ee57eb807410158cc560b03 SHA512 f42b6f5abf4115d745bac73af68562a2c3974347051699cab66cb0e1f7254e52492ddeda51c338498f7f6479226bf4c6e9f46d2c3a8b1f3594244dd9e10dddd9 WHIRLPOOL b7303273d1250de5dd2d85c988a21a427bfb13470096b29963993aee1dd82efc0444c8f953dfd308cddd42b02a5238ffce35c823e3c8774e0d54c515a5aa34ca
+DIST netctl-1.11.tar.xz 43868 SHA256 e154fd8e5dd0057ce2ec542d4dbbb895ff03bb8b3df276a27f4a5ab511d33477 SHA512 00bf4b016d755796980d492305332230a2089e843bf0921a7fd28ef17400e024bac0987a08c4caadf1c19becae73ce7f33d1e51ce1ea9f47e0129e1aff1ccd71 WHIRLPOOL 156e8a26890fc682137ca2cfe5dfb8aeb5e034688c21be2be739e5606ccb9664a27ab4df65f029a4e33a81cf7efcf459fc443e3a309412fb07aaf5cabf44a2ca
DIST netctl-1.9.tar.xz 43256 SHA256 86040e40d28b1f6e12b8a34daa3bc107ef94005d5e0bff9c43ed8e22f7cb4181 SHA512 586cf8389d33c130d2cb94fa35479436a6dba70ff05bc7b59d2c3148760ddb3030f00d06bdb8c09cb6bac4fc0d94a4f3a3ced7d3b30973e58323af1676ef6f42 WHIRLPOOL dbff6d0d8c7389a5ec4da6555fbc8bec3f63a5498049e77148aae8b54d97f0820eada8e3e0458ddd06572d1aafb1cb3378579e4f11aa7433cb86ff6710a6c06e
diff --git a/net-misc/netctl/netctl-1.11.ebuild b/net-misc/netctl/netctl-1.11.ebuild
new file mode 100644
index 00000000000..f558aadc0ee
--- /dev/null
+++ b/net-misc/netctl/netctl-1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="https://sources.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-6.4.0
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To get additional features, a number of optional runtime dependencies may be"
+ elog "installed."
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+ fi
+}
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index db0610a6fef..f558aadc0ee 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$