summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-09-03 20:25:05 -0400
committerBrian Evans <grknight@gentoo.org>2018-09-03 20:25:05 -0400
commita97f793050faa0bb5a9c9fe6e843545382d4b405 (patch)
tree288c632d350f3771e21f87055b47682c7cb50750
parentcb42d4054f6d3531ef4a9956764ddd249ba5b610 (diff)
downloadgentoo-a97f793050faa0bb5a9c9fe6e843545382d4b405.tar.gz
gentoo-a97f793050faa0bb5a9c9fe6e843545382d4b405.tar.xz
dev-php/adodb: Version bump for 5.20.13
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--dev-php/adodb/Manifest1
-rw-r--r--dev-php/adodb/adodb-5.20.13.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/adodb/Manifest b/dev-php/adodb/Manifest
index 7ac84d8d56f..022744eec1a 100644
--- a/dev-php/adodb/Manifest
+++ b/dev-php/adodb/Manifest
@@ -1,2 +1,3 @@
DIST adodb-5.20.12.tar.gz 464962 BLAKE2B 51b1bec4c9bda427988848cd0ff810058e159c75946ea4d14d1ab639545f0c95a8a1a2b8193c8c0403e37fc2e3b858f97b255b9b615b65786d1593269e9da731 SHA512 ac8f36dba459bac15f16ecfd1ece69edc922e67b6aec3641a0c8ffc50c6b1c437ecce2e5652c31f2e472f7abefb3ac5a8a2bef188959007442799784ab764c1e
+DIST adodb-5.20.13.tar.gz 465568 BLAKE2B 7acfe36586fcf0e0291ce9dd6446c6f0922b9c7144b86d8eb0d78db98247fc9ac6aa9b1623822628096c2be0e0e9c554e9c3acbc05d9ddcda1b5c598b8b3652b SHA512 0824de6abf73a8e3fbdde30ca1455264a49e3b711e81c8232bd82c082c0d3f255aea35a167685cd01e80216622db1167c17a518d57b1ed260eaa498cab0b9fca
DIST adodb-5.20.9.tar.gz 464257 BLAKE2B 38a37e4a5b1ac86b37cbd164c79e2112c78fb22530a225d2cac4f916703d4c2bd300a47a214344d8ae9e5c94467ec34cab96ab36a10ad8dad581ec74c73ae111 SHA512 bc40113012c27b759ff35e7395404d1756720e9daef7df4d33147b9950e9ffd032274ccd8808fe303ba75feeaf727e2deb50fc6d79826db96ce568a70007f30f
diff --git a/dev-php/adodb/adodb-5.20.13.ebuild b/dev-php/adodb/adodb-5.20.13.ebuild
new file mode 100644
index 00000000000..f6b55b30633
--- /dev/null
+++ b/dev-php/adodb/adodb-5.20.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ADOdb"
+DESCRIPTION="Database abstraction layer for PHP"
+HOMEPAGE="https://github.com/ADOdb"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# If you want to be picky, we should require that PHP be built with at
+# least one database driver enabled; otherwise adodb isn't going to be
+# able to do anything. But, the database USE flags for dev-lang/php are
+# a mess. What we would *like* to do is have a set of USE flags for
+# adodb that then propagate to PHP itself... for example, adodb[mysql]
+# could require php[mysql]. To do that would require that we duplicate
+# the database USE flag mess for adodb -- not desirable. Instead we punt
+# and let the user install adodb unconditionally. If he doesn't have
+# database support in PHP, it just won't work.
+RDEPEND="dev-lang/php:*"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ DOCS="README.md docs/changelog*.md xmlschema*.dtd session/*.sql"
+ DOCS+=" session/*.txt session/*.xml pear/auth_adodb_example.php"
+ DOCS+=" pear/readme.Auth.txt"
+
+ dodoc $DOCS
+ rm -f $DOCS || die "failed to remove docs before installation"
+
+ insinto "/usr/share/php/${PN}"
+ doins *.php
+ doins -r contrib datadict drivers lang pear perf replicate session xsl
+}