summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-27 22:29:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-27 22:29:56 +0100
commita9ec7d44540eb59772ffa97ff58fa5386042b07c (patch)
tree9dd8cb433b3ffcc38488009e1eef92366fe53fdc
parent9600b6abaf80099ac96186e78c6a36c20fef8f6d (diff)
downloadgentoo-a9ec7d44540eb59772ffa97ff58fa5386042b07c.tar.gz
gentoo-a9ec7d44540eb59772ffa97ff58fa5386042b07c.tar.xz
dev-libs/chmlib: Port to EAPI 6
Closes: https://bugs.gentoo.org/642272 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild19
-rw-r--r--dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch4
-rw-r--r--dev-libs/chmlib/files/chmlib-0.40-headers.patch4
3 files changed, 16 insertions, 11 deletions
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
index 88496bdb5c5..f1e56dc5286 100644
--- a/dev-libs/chmlib/chmlib-0.40-r1.ebuild
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Library for MS CHM (compressed html) file format"
HOMEPAGE="http://www.jedrea.com/chmlib/"
@@ -14,13 +14,18 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 x86"
IUSE="+examples static-libs"
-DOCS=(AUTHORS NEWS README)
PATCHES=(
"${FILESDIR}"/${PN}-0.39-stdtypes.patch
"${FILESDIR}"/${P}-headers.patch
)
-src_configure() {
- myeconfargs=($(use_enable examples))
- autotools-utils_src_configure
+my_src_configure() {
+ econf \
+ $(use_enable examples) \
+ $(use_enable static-libs static)
+}
+
+my_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch b/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch
index 0f923201768..c0b809b2d9d 100644
--- a/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch
+++ b/dev-libs/chmlib/files/chmlib-0.39-stdtypes.patch
@@ -1,5 +1,5 @@
---- src/chm_lib.c
-+++ src/chm_lib.c
+--- a/src/chm_lib.c
++++ b/src/chm_lib.c
@@ -149,6 +149,17 @@ typedef unsigned __int32 UInt32;
typedef __int64 Int64;
typedef unsigned __int64 UInt64;
diff --git a/dev-libs/chmlib/files/chmlib-0.40-headers.patch b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
index d60af28639f..5daa458be8a 100644
--- a/dev-libs/chmlib/files/chmlib-0.40-headers.patch
+++ b/dev-libs/chmlib/files/chmlib-0.40-headers.patch
@@ -1,5 +1,5 @@
---- src/chm_http.c
-+++ src/chm_http.c
+--- a/src/chm_http.c
++++ b/src/chm_http.c
@@ -34,6 +34,7 @@
#include <stdio.h>
#include <stdlib.h>