summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-08-01 21:02:33 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-08-01 21:22:29 -0500
commitb9f532c895d1a3ab2c47f500d3f8c23d8707aecf (patch)
tree24c9d735e19600352c981914bc3366dc41d68f2d
parentcbf81c84f5ab42620b9e19fcb9ff1b0d19416354 (diff)
downloadgentoo-b9f532c895d1a3ab2c47f500d3f8c23d8707aecf.tar.gz
gentoo-b9f532c895d1a3ab2c47f500d3f8c23d8707aecf.tar.xz
net-misc/spice-gtk: version bump to 0.32
Thanks to Yixun Lun (dlan) for all the work! Package-Manager: portage-2.2.28
-rw-r--r--net-misc/spice-gtk/Manifest1
-rw-r--r--net-misc/spice-gtk/metadata.xml1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32.ebuild145
3 files changed, 147 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/Manifest b/net-misc/spice-gtk/Manifest
index 9bd64db3b88..db07b0db92a 100644
--- a/net-misc/spice-gtk/Manifest
+++ b/net-misc/spice-gtk/Manifest
@@ -1 +1,2 @@
DIST spice-gtk-0.31.tar.bz2 1340962 SHA256 c72b4d202b1c0b71d6e24ce5caf914d6dddbcf4010d10db9c2d8e73af728c1ca SHA512 f4aeaa8571829235c9f70b31676998d5c2c691619e63c26d374c62c3be9c2b4a0598f0fa7c5cce1db13fa60fd3b4d6053ce263fbd714add1f2791519a5c5038a WHIRLPOOL b0a2684288890c3dd7c07e56abd037eba1aa337b8bf8ec8c3dc9ceddd80772ab2eee36b4e021a5a08a86180c50625a495aa0b23f9da28508b5dafb165537c8ee
+DIST spice-gtk-0.32.tar.bz2 1342742 SHA256 4c48f4099335e0cd100854162a44070d34ed73dfcad2115e80c075013b49ee02 SHA512 6c677c814b9256404effdab177695e186342f81aa11cfe8ff49df8d0ee19b7c7ed51468b75b32318a763c826a46832c9dfe93ba8dc4d1ef7d5943b7db2160f45 WHIRLPOOL 9ba5793f8f8a08307b149d4ff3286ce885bee8b2203e634f64519443ac7d55a83d2e1dc2e351d1c862833fcf5056b6cf0e5de61a18062ca513d0c71e8bcb3856
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
index 92aeee0dbd5..83884db317a 100644
--- a/net-misc/spice-gtk/metadata.xml
+++ b/net-misc/spice-gtk/metadata.xml
@@ -16,6 +16,7 @@
usbredir acl helper</flag>
<flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
devices to another machine over TCP</flag>
+ <flag name="mjpeg">Enable builtin mjpeg video decoder</flag>
<flag name="webdav">Support for folder-sharing between guest and client
using <pkg>net-libs/phodav</pkg></flag>
</use>
diff --git a/net-misc/spice-gtk/spice-gtk-0.32.ebuild b/net-misc/spice-gtk/spice-gtk-0.32.ebuild
new file mode 100644
index 00000000000..19402ba514e
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.32.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+WANT_AUTOMAKE="1.12"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils vala
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="http://spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus doc gstreamer gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
+
+REQUIRED_USE="
+ ?? ( pulseaudio gstreamer )
+"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0 )
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ media-libs/opus
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg:0=
+ sys-libs/zlib
+ introspection? ( dev-libs/gobject-introspection )
+ lz4? ( app-arch/lz4 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/libgudev:=
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ !~sys-auth/polkit-0.111 )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=dev-libs/glib-2.43.90:2
+ >=net-libs/libsoup-2.49.91 )
+"
+DEPEND="${RDEPEND}
+ ~app-emulation/spice-protocol-0.12.11
+ dev-perl/Text-CSV
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+
+# Prevent sandbox violations, bug #581836
+# https://bugzilla.gnome.org/show_bug.cgi?id=581836
+addpredict /dev
+
+src_prepare() {
+ epatch_user
+
+ AT_NO_RECURSIVE="yes" eautoreconf
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
+
+ myconf="
+ --disable-maintainer-mode \
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ $(use_enable usbredir) \
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
+ $(use_with gtk3 gtk 3.0) \
+ $(use_enable policykit polkit) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable gstreamer gstaudio) \
+ $(use_enable gstreamer gstvideo) \
+ $(use_enable mjpeg builtin-mjpeg) \
+ $(use_enable vala) \
+ $(use_enable webdav) \
+ $(use_enable dbus) \
+ --disable-werror \
+ --enable-pie"
+
+ if use gtk3; then
+ myconf+=" \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-html)"
+ else
+ myconf+=" \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html"
+ fi
+
+ econf ${myconf}
+}
+
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ # Make sure no gtk-doc bits are installed for -doc
+ use doc || rm -rf "${ED}usr/share/gtk-doc"
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+}