summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-01 22:19:17 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:23 +0000
commitbaa70e7004bed1d1c475fe10a0c34d9a7cef27b4 (patch)
treef4abac6504f7cf79cce7a9418400e4f6de6a72ae
parent5fae0670903bc4b1541e6cb7e8e3375989eca6ce (diff)
downloadgentoo-baa70e7004bed1d1c475fe10a0c34d9a7cef27b4.tar.gz
gentoo-baa70e7004bed1d1c475fe10a0c34d9a7cef27b4.tar.xz
dev-python/sphinxcontrib-blockdiag: add namespace dependency and fix bug #623852
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
new file mode 100644
index 00000000000..775f0da1e16
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-1.5.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+
+HOMEPAGE="https://github.com/blockdiag/sphinxcontrib-blockdiag"
+
+SRC_URI="https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e /build-base/d setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}