summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 21:07:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 21:07:26 -0500
commitbec393032d116ec9908bee82c6436bf578595e82 (patch)
tree3f8cdb99169aab289f6d1bbe35ed7b9d3fac2fa9
parent96ead2b01ebd7d7b60c88d178cc639b8f61afde4 (diff)
downloadgentoo-bec393032d116ec9908bee82c6436bf578595e82.tar.gz
gentoo-bec393032d116ec9908bee82c6436bf578595e82.tar.xz
dev-python/pecan: adding py35
Package-Manager: portage-2.2.26
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 78b52be8582..289c91fca19 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1,2 +1,3 @@
DIST pecan-1.0.2.tar.gz 206278 SHA256 09ec440bd20821ba1170667ce9994712701416eaa6044cfe7c647aa5e291c5bd SHA512 af680881f37c4b489c0dcf58786f1a49a172921bb534e8b54dced794b0d2097f2c29d0ba11b740affd85756eb244afc465d20023295ec4fbb857371c63199ddb WHIRLPOOL 9ff31797ef3e3c0123f0aaf990dfc646dc65d7f4887d36c2190e80f8b1cb5f0bf52068c9d467c05b939ac17c571224dde2f0ca5d00bd1f757f0834184a705383
DIST pecan-1.0.3.tar.gz 119309 SHA256 8d6c99709a9e0ba0752b23e0b4759b7b33e8d8650ee45c1f5f5fa2a596af4b11 SHA512 f1ee856085d740afb60caebe73f9083aea3dcce9a0fbcb7cc5b93909014a01b9c3987c4dc241075578ab8d6e4798160cd393aacb1d783c2397b2fea6771de456 WHIRLPOOL 13da73b372905446e1e89827115e2201ae4e9e9a5fc1cf4e2c22c0ad875d17960d2224a59271048f196d4869ea21552cd3b6fefba7658534eff03b05df7ea36b
+DIST pecan-1.0.4.tar.gz 119575 SHA256 0ecaa56bd3e1643af671dda9c293992b0e086c52cd7d19ab37bd56169a6effa8 SHA512 cbd5bc21658e68553baa55b74f82f7198ba261bf48d2889732ebbdbcb7f00d0a68f85dcaf946e7349000e78217c532d2017606316335211abd1fac15b947ed7f WHIRLPOOL d13c61ea5fced23a745c05f006218e5851418563fb5199fbdf20652edd0aea4d552407ef7ff9d8b4bb32f53c5bfc7d3767e79ba02bb206910a89aa8a90f9c1df
diff --git a/dev-python/pecan/pecan-1.0.4.ebuild b/dev-python/pecan/pecan-1.0.4.ebuild
new file mode 100644
index 00000000000..b5963023b64
--- /dev/null
+++ b/dev-python/pecan/pecan-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, designed to be lean and fast, with few dependencies."
+HOMEPAGE="https://pypi.python.org/pypi/pecan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"