summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-07-02 14:42:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-02 15:09:43 +0200
commitc02abc9dbb16406c03110c8c3cec214827eef031 (patch)
treec80bc4aececfea8685abd9bbe5ea8695887ce3f2
parentb5e02a349732e8ddecc9799e09bdc3e9c63d3d63 (diff)
downloadgentoo-c02abc9dbb16406c03110c8c3cec214827eef031.tar.gz
gentoo-c02abc9dbb16406c03110c8c3cec214827eef031.tar.xz
dev-python/pycipher: Modernize to python-r1 suite
* EAPI=6 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/1814 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/pycipher/pycipher-0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycipher/pycipher-0.2-r1.ebuild b/dev-python/pycipher/pycipher-0.2-r1.ebuild
new file mode 100644
index 00000000000..40d801dc280
--- /dev/null
+++ b/dev-python/pycipher/pycipher-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
+HOMEPAGE="http://pycipher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.py"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}/${A}" "${S}/${PN}.py" || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule ${PN}.py
+}