summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-06 09:39:09 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-07 18:01:27 +0100
commitc2a444eb704a4a2120605687dfeb10e8668ed87a (patch)
tree6c8982ad22bc12bde4b82f816e46a754ac4a55a1
parentb6e92d84d0b943c435c4fbd271079ff4cd4a42ff (diff)
downloadgentoo-c2a444eb704a4a2120605687dfeb10e8668ed87a.tar.gz
gentoo-c2a444eb704a4a2120605687dfeb10e8668ed87a.tar.xz
app-portage/unsymlink-lib: SYMLINK_LIB=no migration tool
-rw-r--r--app-portage/unsymlink-lib/Manifest1
-rw-r--r--app-portage/unsymlink-lib/metadata.xml12
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-1.ebuild24
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild25
4 files changed, 62 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
new file mode 100644
index 00000000000..61d6c0ffe81
--- /dev/null
+++ b/app-portage/unsymlink-lib/Manifest
@@ -0,0 +1 @@
+DIST unsymlink-lib-1.tar.gz 6000 BLAKE2B d9263d973ab70ffb77aa8c90f0b4562a8214ae4c9d111cf7a19172b2e62427cbce4a5ffa0a3c020b4a599274d664eaf60967922315f414eed3f9321f3863a736 SHA512 f27640cbcc67ef1ff5a24c8e8d17955eb0cc745465b3ee831d9a06da37c058279311f230846cc350160cfcce1b80e74defedad8ebd59abd2a6d2a59af9c39500
diff --git a/app-portage/unsymlink-lib/metadata.xml b/app-portage/unsymlink-lib/metadata.xml
new file mode 100644
index 00000000000..975c323b513
--- /dev/null
+++ b/app-portage/unsymlink-lib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/mgorny/unsymlink-lib/issues/</bugs-to>
+ <remote-id type="github">mgorny/unsymlink-lib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-1.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-1.ebuild
new file mode 100644
index 00000000000..c5194b936c2
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild
new file mode 100644
index 00000000000..8f99997dcec
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit git-r3 python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mgorny/unsymlink-lib.git"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}