summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2016-01-13 02:18:05 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2016-01-13 02:18:05 +0100
commitc775cf1990878ca40eea47c14feabf8bc683c3fc (patch)
treee1d22e4b5d5c4021f186c30d52d2acdf8964f8be
parent0b20a40c85cb39675282e577ba6b53bacab4f35e (diff)
downloadgentoo-c775cf1990878ca40eea47c14feabf8bc683c3fc.tar.gz
gentoo-c775cf1990878ca40eea47c14feabf8bc683c3fc.tar.xz
dev-games/openscenegraph: add patch to support giflib5, bug 571656
Package-Manager: portage-2.2.26
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.2.1-giflib5.patch24
-rw-r--r--dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.2.1-giflib5.patch b/dev-games/openscenegraph/files/openscenegraph-3.2.1-giflib5.patch
new file mode 100644
index 00000000000..bd604c3c19c
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.2.1-giflib5.patch
@@ -0,0 +1,24 @@
+From: Alberto Luaces <aluaces@udc.es>
+Date: Sat, 19 Dec 2015 04:52:52 +0100
+Subject: Compatibility with giflib5.
+
+---
+ OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+Index: git2/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
+===================================================================
+--- git2.orig/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
++++ git2/OpenSceneGraph/src/osgPlugins/gif/ReaderWriterGIF.cpp
+@@ -561,7 +561,11 @@ GifImageStream** obj)
+ *width_ret = giffile->SWidth;
+ *height_ret = giffile->SHeight;
+ *numComponents_ret = 4;
++#if (GIFLIB_MAJOR >= 5&& !(GIFLIB_MAJOR == 5 && GIFLIB_MINOR == 0))
++ DGifCloseFile(giffile, &Error);
++#else
+ DGifCloseFile(giffile);
++#endif
+ return buffer;
+ }
+
diff --git a/dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild b/dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild
index 37499a8fa2b..9ec683ada09 100644
--- a/dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild
+++ b/dev-games/openscenegraph/openscenegraph-3.2.1-r2.ebuild
@@ -91,6 +91,7 @@ DOCS=(AUTHORS.txt ChangeLog NEWS.txt)
PATCHES=(
"${FILESDIR}"/${PN}-3.2.1-cmake.patch
"${FILESDIR}"/${PN}-3.2.1-gdal-2.0.patch
+ "${FILESDIR}"/${PN}-3.2.1-giflib5.patch
)
src_configure() {