summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-04-11 04:35:10 +0300
committerMart Raudsepp <leio@gentoo.org>2017-04-11 04:52:02 +0300
commitcd4ccb9ea11b995ec9ecc751ab57241fbef78195 (patch)
tree5f9ecac38eb68f7bc09564310d23b45d31fdb39e
parentc074e567165d91ad11ca43e3f398c462a745b857 (diff)
downloadgentoo-cd4ccb9ea11b995ec9ecc751ab57241fbef78195.tar.gz
gentoo-cd4ccb9ea11b995ec9ecc751ab57241fbef78195.tar.xz
dev-libs/glib: Export PCRE_LIBS in the no-pkgconfig case
We have by now started to use the system libpcre unconditionally, instead of the bundled version, but this needs pkgconfig to be found. So we need to handle this in the no-pkgconfig case as well, alongside FFI. However this suggests there is no point in this case anymore and we should just build depend on pkgconfig, as we can't get a working pkgconfig anymore without bootstrapping it via USE=internal-glib as libpcre currently needs pkgconfig as a build dependency already. Until this is still in the pondering phase, this PCRE_LIBS exporting should at least fix the cases where pkgconfig got depcleaned inbetween but libpcre exists on system. Gentoo-bug: 615092
-rw-r--r--dev-libs/glib/glib-2.50.3-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.50.3-r1.ebuild b/dev-libs/glib/glib-2.50.3-r1.ebuild
index 6ba56d741c2..deabfe82c59 100644
--- a/dev-libs/glib/glib-2.50.3-r1.ebuild
+++ b/dev-libs/glib/glib-2.50.3-r1.ebuild
@@ -148,6 +148,8 @@ multilib_src_configure() {
fi
export LIBFFI_CFLAGS="-I$(echo /usr/$(get_libdir)/libffi-*/include)"
export LIBFFI_LIBS="-lffi"
+ export PCRE_CFLAGS=""
+ export PCRE_LIBS="-lpcre"
fi
# These configure tests don't work when cross-compiling.