summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-11 20:40:36 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-11 21:05:32 -0600
commitda44fb3021696c27781b9cf9426d84a254a4a10e (patch)
treedaeb61d5eae3efb6ac60815410dd7639e36f95a1
parent33cc41f10b77da8f1ce20794b6aaa8af7f447593 (diff)
downloadgentoo-da44fb3021696c27781b9cf9426d84a254a4a10e.tar.gz
gentoo-da44fb3021696c27781b9cf9426d84a254a4a10e.tar.xz
sys-apps/usbredir: version bump to _p20180211
Also fix usbredirtestclient Closes: https://bugs.gentoo.org/627386 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/usbredir/Manifest1
-rw-r--r--sys-apps/usbredir/usbredir-0.7.1_p20180211.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/usbredir/Manifest b/sys-apps/usbredir/Manifest
index 7096d1802c2..1bc452f0087 100644
--- a/sys-apps/usbredir/Manifest
+++ b/sys-apps/usbredir/Manifest
@@ -1,2 +1,3 @@
DIST usbredir-0.7.1.tar.bz2 329895 BLAKE2B 7017b1441c2265c9e58532bcc8718844e6f64c7272ad599a8cf5f6e21f694524e05da2d8672c4892faa7b744be46bdfff521dbcb4944715d45b24d5925972ac4 SHA512 f8d26d59d5a530aa413fabe2402fbbd9662760453c2b4e83d34f2e5287c188114ea870f15ae1bc910297649986315be965f0d23d0a2b7b0cec2f207fc65d7598
DIST usbredir-0.7.1_p20170503-patches.tar.xz 8120 BLAKE2B 21c7a853b3d5329fcca45169e22135bce615c9422f314f680f1087014d64179bf26f07bdb377bcff48155f28a37dec82b0bee8bce4d868e41614b128fe61b95a SHA512 b281d7a1ee191746e5fbe655b21c0cd9b2cf9cd69d5f28d91ab41de2d62a7f3c5c2a42f3f9c40c73d61a57d89423d996f4a779ebdff8f9d088030c2a4c2a24a7
+DIST usbredir-0.7.1_p20180211-patches.tar.xz 12508 BLAKE2B 57479444752070147583a0cc2f6651a32c8a618756638ae04928dda7082214d501fb5122a0f5d02aca994be0a386a8e493628faa240f61987dbd02d2fcfa679a SHA512 993c7ad5faf66f249546e1a631a10cd842439486de029ed2fff049b70967cb0a6ad45fb773a1c97fd6811e246f4cc4c7482522393dcc74b26ba2646a83ac70c8
diff --git a/sys-apps/usbredir/usbredir-0.7.1_p20180211.ebuild b/sys-apps/usbredir/usbredir-0.7.1_p20180211.ebuild
new file mode 100644
index 00000000000..511853883be
--- /dev/null
+++ b/sys-apps/usbredir/usbredir-0.7.1_p20180211.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic
+
+MY_PV=${PV/_p*/}
+
+DESCRIPTION="TCP daemon and set of libraries for usbredir protocol (redirecting USB traffic)"
+HOMEPAGE="https://www.spice-space.org/page/UsbRedir"
+SRC_URI="https://www.spice-space.org/download/usbredir/usbredir-${MY_PV}.tar.bz2
+ https://dev.gentoo.org/~tamiko/distfiles/${P}-patches.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+PATCHES=(
+ "${S}_p20180211-patches"
+)
+
+DOCS="ChangeLog README* TODO *.txt"
+
+src_configure() {
+ # https://bugs.freedesktop.org/show_bug.cgi?id=54643
+ append-cflags -Wno-error
+
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ # noinst_PROGRAMS
+ dobin usbredirtestclient/.libs/usbredirtestclient
+}