summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-06 12:03:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-06 12:03:15 +0200
commitdb6d1633b835a81bb34c020f794ec9c99c113384 (patch)
treeeffddf55ee8f5507add513e5675e6181fec46709
parent8bc6649a69e566c5f6b94093d1232afabc4ce68f (diff)
downloadgentoo-db6d1633b835a81bb34c020f794ec9c99c113384.tar.gz
gentoo-db6d1633b835a81bb34c020f794ec9c99c113384.tar.xz
dev-ml/calendar: bump to 2.04
Package-Manager: portage-2.3.0
-rw-r--r--dev-ml/calendar/Manifest1
-rw-r--r--dev-ml/calendar/calendar-2.04.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/calendar/Manifest b/dev-ml/calendar/Manifest
index caaba3ba040..061080af952 100644
--- a/dev-ml/calendar/Manifest
+++ b/dev-ml/calendar/Manifest
@@ -1 +1,2 @@
DIST calendar-2.03.2.tar.gz 270225 SHA256 0e381faaa3bba522cbac705a7f872e6ecfa15220671f4688d1e311631687fb12 SHA512 c6acc326aaed77d238126f8723a8e3e4054808ddfef974d9aead39731f4ab9f386eff2f34aab17e4eade3825dd1e3b708a404ecde3fc9b82416482c7095de82b WHIRLPOOL 68505b62aee8b41c53aae81a3a3d22776867c4885461f1fac33365b4a03cc8d7e4e1ebfa8bf72fc6665d3eb7eb2ca4ae93b98989bd76f22931103707a1b3712c
+DIST calendar-2.04.tar.gz 271522 SHA256 bea6faa0337a1c54b0f3c2b9b45c9eb90e2b2747406e6f0b841e1fd20fd4d9f7 SHA512 3941768428eda47f47912846cc2921ee82c722bda7cf6095c1c8bdcfebc19bb8f64ebb1a25475396d2a49c186b83421af63602a54a261684117b1c036a66cf3d WHIRLPOOL 64e041dd0b9c8ab9128d2b79a7b62d761e2d74b3388822335807b8c05f3a453bc0ca17c58d0728fa56f1255f8f7b6f779ed6ba27c761c525bdbe1f19e1125f4b
diff --git a/dev-ml/calendar/calendar-2.04.ebuild b/dev-ml/calendar/calendar-2.04.ebuild
new file mode 100644
index 00000000000..cd3126dc9cd
--- /dev/null
+++ b/dev-ml/calendar/calendar-2.04.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="An Ocaml library to handle dates and time"
+HOMEPAGE="http://forge.ocamlcore.org/projects/calendar/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1481/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES
+ use doc && dohtml -r doc
+}