summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-22 10:57:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-03-22 10:57:46 +0100
commitdccd36167ab666ad7b8938aedc534ffe9b10f18b (patch)
tree8f444704358576a1022a1357d8c04c40a8918b2f
parent8a455c1d764b11fcb136cb8f2bf3469ce4c642fd (diff)
downloadgentoo-dccd36167ab666ad7b8938aedc534ffe9b10f18b.tar.gz
gentoo-dccd36167ab666ad7b8938aedc534ffe9b10f18b.tar.xz
dev-ros/tf2: Remove old
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-ros/tf2/Manifest2
-rw-r--r--dev-ros/tf2/files/logging.patch98
-rw-r--r--dev-ros/tf2/files/logging2.patch98
-rw-r--r--dev-ros/tf2/tf2-0.5.16-r1.ebuild26
-rw-r--r--dev-ros/tf2/tf2-0.5.17.ebuild26
5 files changed, 0 insertions, 250 deletions
diff --git a/dev-ros/tf2/Manifest b/dev-ros/tf2/Manifest
index 1a47dd9af38..91aa82a2172 100644
--- a/dev-ros/tf2/Manifest
+++ b/dev-ros/tf2/Manifest
@@ -1,3 +1 @@
-DIST geometry2-0.5.16.tar.gz 154351 BLAKE2B e630be09da6de544de0215d40ffcb0aa780be253320264d52603d5fe7506d12b27e986acb9c036973ba390c5cd96b5e838849ee2f5b1399148cf5cffb461cd76 SHA512 11909db98af78bbdef8d1a7dc5f20d3ff3cfcb0afc0e1d53b97a1ffe99aecea911f09364593eb232d7514a4caa192141404d892a33fc7ea9f5ce924ecf99fc51
-DIST geometry2-0.5.17.tar.gz 156516 BLAKE2B 72f936086fe3dbcfa3c05f7ae72e64f20fd1525513e79ed9c4dae7c5b097501ea230c483a3f1eb6e0ba6a342e0ddc5deacf05ec9f0c97b56df48dcf2bf669e8b SHA512 44d91796f03d0cbd8a9247568827dca4a848ec931fa754fd7815e9102f7bcac38e85ebcc27e3037827358dbfbc7d58b28775f00e1e04c48125e56c7b97cde925
DIST geometry2-0.6.1.tar.gz 162912 BLAKE2B 103937894921111da2058f61b555cb9498ea053e8c8dac357383fc326e214bf88e74a65c97021cf7dd0ecb2b5a38606c3ad3660e365af145349c764660c56726 SHA512 392719295eedf4a5f580390f076a14f9909f49681223d8c50ccb88d57b784c1e50383d28ff10bddc21424662f261504c29525c24965a51462d6e9e62d702d6ef
diff --git a/dev-ros/tf2/files/logging.patch b/dev-ros/tf2/files/logging.patch
deleted file mode 100644
index 20ce562b1f3..00000000000
--- a/dev-ros/tf2/files/logging.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-Index: tf2/src/buffer_core.cpp
-===================================================================
---- tf2.orig/src/buffer_core.cpp
-+++ tf2/src/buffer_core.cpp
-@@ -123,7 +123,7 @@ bool BufferCore::warnFrameId(const char*
- {
- std::stringstream ss;
- ss << "Invalid argument passed to "<< function_name_arg <<" in tf2 frame_ids cannot be empty";
-- logWarn("%s",ss.str().c_str());
-+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
- return true;
- }
-
-@@ -131,7 +131,7 @@ bool BufferCore::warnFrameId(const char*
- {
- std::stringstream ss;
- ss << "Invalid argument \"" << frame_id << "\" passed to "<< function_name_arg <<" in tf2 frame_ids cannot start with a '/' like: ";
-- logWarn("%s",ss.str().c_str());
-+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
- return true;
- }
-
-@@ -218,26 +218,26 @@ bool BufferCore::setTransform(const geom
- bool error_exists = false;
- if (stripped.child_frame_id == stripped.header.frame_id)
- {
-- logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
-+ CONSOLE_BRIDGE_logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
- error_exists = true;
- }
-
- if (stripped.child_frame_id == "")
- {
-- logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
-+ CONSOLE_BRIDGE_logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
- error_exists = true;
- }
-
- if (stripped.header.frame_id == "")
- {
-- logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
-+ CONSOLE_BRIDGE_logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
- error_exists = true;
- }
-
- if (std::isnan(stripped.transform.translation.x) || std::isnan(stripped.transform.translation.y) || std::isnan(stripped.transform.translation.z)||
- std::isnan(stripped.transform.rotation.x) || std::isnan(stripped.transform.rotation.y) || std::isnan(stripped.transform.rotation.z) || std::isnan(stripped.transform.rotation.w))
- {
-- logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
-+ CONSOLE_BRIDGE_logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
- stripped.child_frame_id.c_str(), authority.c_str(),
- stripped.transform.translation.x, stripped.transform.translation.y, stripped.transform.translation.z,
- stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w
-@@ -252,7 +252,7 @@ bool BufferCore::setTransform(const geom
-
- if (!valid)
- {
-- logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
-+ CONSOLE_BRIDGE_logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
- stripped.child_frame_id.c_str(), authority.c_str(),
- stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w);
- error_exists = true;
-@@ -274,7 +274,7 @@ bool BufferCore::setTransform(const geom
- }
- else
- {
-- logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
-+ CONSOLE_BRIDGE_logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
- return false;
- }
- }
-@@ -622,7 +622,7 @@ geometry_msgs::TransformStamped BufferCo
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
-@@ -1593,7 +1593,7 @@ void BufferCore::_chainAsVector(const st
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
-@@ -1613,7 +1613,7 @@ void BufferCore::_chainAsVector(const st
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
diff --git a/dev-ros/tf2/files/logging2.patch b/dev-ros/tf2/files/logging2.patch
deleted file mode 100644
index 38a3ee3c0bb..00000000000
--- a/dev-ros/tf2/files/logging2.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-Index: tf2/src/buffer_core.cpp
-===================================================================
---- tf2.orig/src/buffer_core.cpp
-+++ tf2/src/buffer_core.cpp
-@@ -123,7 +123,7 @@ bool BufferCore::warnFrameId(const char*
- {
- std::stringstream ss;
- ss << "Invalid argument passed to "<< function_name_arg <<" in tf2 frame_ids cannot be empty";
-- logWarn("%s",ss.str().c_str());
-+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
- return true;
- }
-
-@@ -131,7 +131,7 @@ bool BufferCore::warnFrameId(const char*
- {
- std::stringstream ss;
- ss << "Invalid argument \"" << frame_id << "\" passed to "<< function_name_arg <<" in tf2 frame_ids cannot start with a '/' like: ";
-- logWarn("%s",ss.str().c_str());
-+ CONSOLE_BRIDGE_logWarn("%s",ss.str().c_str());
- return true;
- }
-
-@@ -218,26 +218,26 @@ bool BufferCore::setTransform(const geom
- bool error_exists = false;
- if (stripped.child_frame_id == stripped.header.frame_id)
- {
-- logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
-+ CONSOLE_BRIDGE_logError("TF_SELF_TRANSFORM: Ignoring transform from authority \"%s\" with frame_id and child_frame_id \"%s\" because they are the same", authority.c_str(), stripped.child_frame_id.c_str());
- error_exists = true;
- }
-
- if (stripped.child_frame_id == "")
- {
-- logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
-+ CONSOLE_BRIDGE_logError("TF_NO_CHILD_FRAME_ID: Ignoring transform from authority \"%s\" because child_frame_id not set ", authority.c_str());
- error_exists = true;
- }
-
- if (stripped.header.frame_id == "")
- {
-- logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
-+ CONSOLE_BRIDGE_logError("TF_NO_FRAME_ID: Ignoring transform with child_frame_id \"%s\" from authority \"%s\" because frame_id not set", stripped.child_frame_id.c_str(), authority.c_str());
- error_exists = true;
- }
-
- if (std::isnan(stripped.transform.translation.x) || std::isnan(stripped.transform.translation.y) || std::isnan(stripped.transform.translation.z)||
- std::isnan(stripped.transform.rotation.x) || std::isnan(stripped.transform.rotation.y) || std::isnan(stripped.transform.rotation.z) || std::isnan(stripped.transform.rotation.w))
- {
-- logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
-+ CONSOLE_BRIDGE_logError("TF_NAN_INPUT: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of a nan value in the transform (%f %f %f) (%f %f %f %f)",
- stripped.child_frame_id.c_str(), authority.c_str(),
- stripped.transform.translation.x, stripped.transform.translation.y, stripped.transform.translation.z,
- stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w
-@@ -252,7 +252,7 @@ bool BufferCore::setTransform(const geom
-
- if (!valid)
- {
-- logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
-+ CONSOLE_BRIDGE_logError("TF_DENORMALIZED_QUATERNION: Ignoring transform for child_frame_id \"%s\" from authority \"%s\" because of an invalid quaternion in the transform (%f %f %f %f)",
- stripped.child_frame_id.c_str(), authority.c_str(),
- stripped.transform.rotation.x, stripped.transform.rotation.y, stripped.transform.rotation.z, stripped.transform.rotation.w);
- error_exists = true;
-@@ -274,7 +274,7 @@ bool BufferCore::setTransform(const geom
- }
- else
- {
-- logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
-+ CONSOLE_BRIDGE_logWarn("TF_OLD_DATA ignoring data from the past for frame %s at time %g according to authority %s\nPossible reasons are listed at http://wiki.ros.org/tf/Errors%%20explained", stripped.child_frame_id.c_str(), stripped.header.stamp.toSec(), authority.c_str());
- return false;
- }
- }
-@@ -633,7 +633,7 @@ geometry_msgs::TransformStamped BufferCo
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
-@@ -1604,7 +1604,7 @@ void BufferCore::_chainAsVector(const st
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
-@@ -1623,7 +1623,7 @@ void BufferCore::_chainAsVector(const st
- case tf2_msgs::TF2Error::LOOKUP_ERROR:
- throw LookupException(error_string);
- default:
-- logError("Unknown error code: %d", retval);
-+ CONSOLE_BRIDGE_logError("Unknown error code: %d", retval);
- assert(0);
- }
- }
diff --git a/dev-ros/tf2/tf2-0.5.16-r1.ebuild b/dev-ros/tf2/tf2-0.5.16-r1.ebuild
deleted file mode 100644
index 55afc005d04..00000000000
--- a/dev-ros/tf2/tf2-0.5.16-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros/geometry2"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="The second generation Transform Library in ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/console_bridge:=
- dev-ros/rostime
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}
- test? ( dev-ros/roscpp )
-"
-PATCHES=( "${FILESDIR}/logging.patch" )
diff --git a/dev-ros/tf2/tf2-0.5.17.ebuild b/dev-ros/tf2/tf2-0.5.17.ebuild
deleted file mode 100644
index 775ef1258bc..00000000000
--- a/dev-ros/tf2/tf2-0.5.17.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros/geometry2"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="The second generation Transform Library in ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/console_bridge:=
- dev-ros/rostime
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}
- test? ( dev-ros/roscpp )
-"
-PATCHES=( "${FILESDIR}/logging2.patch" )