summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2016-04-11 10:04:19 +0200
committerThomas Kahle <tomka@gentoo.org>2016-04-11 10:04:38 +0200
commitf07bd346d5716ee9afbf8e12804fcef4fb7bc7f9 (patch)
tree2432aadc6d531b858aa0e90cdfbf1d7b746e32f6
parent0934d916f62664f189e133643acadb44b326b6af (diff)
downloadgentoo-f07bd346d5716ee9afbf8e12804fcef4fb7bc7f9.tar.gz
gentoo-f07bd346d5716ee9afbf8e12804fcef4fb7bc7f9.tar.xz
sci-mathematics/gimps: bump to 28.9 and EAPI=6
Thanks to Paolo Pedroni in bug 579084. Package-Manager: portage-2.2.26
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-28.9.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 526e8c64720..370b7b29bb8 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -1,2 +1,4 @@
DIST p95v287.linux32.tar.gz 4610011 SHA256 836ad76a17762dca50c2bed55c9e46655268e42b0de1c87e2499e92602e41435 SHA512 2f60c2801f02b6f72e71704f99f94512483da192d659fd691e3be2b562cdc4f174e744c276173b2b17b6c664be998d5b483e4aeda9e716afbc885e87cc919060 WHIRLPOOL c57f34beb0b46b6f5c822a63ae3281b70ca69167589d1b3b33c1e455da1f476cbfa8213c1053c2aedbc9f543cba7c3a1ac2d4ed2a98e7d6433be6ba2c47c32ed
DIST p95v287.linux64.tar.gz 5661102 SHA256 3555426f170ae222de34599aca8dac9c621923a3e7d492d25138c086f45536ab SHA512 8e35af16bffe1e624f08797baa67d8890fd62a6b6ada1cbd1b4d37afb60e08f9f58dc8e566e0bc6e5e8fb714367e78c30dbff8b77c76a47d7b0935d10afd4c48 WHIRLPOOL 36ce137654d9a7a02643940349f0465d4a4592f4e35158b3d5512e2d5e24ea1f86105ec6cebff1369200ab45d8e5968c32d94ea2f747e666df444a4e13049d0e
+DIST p95v289.linux32.tar.gz 4610947 SHA256 75eb6237a41a08276347ec57bcea5e40e2e2af667dbdeec665939f03f1edc4cf SHA512 3b7428d0c94a2076efc1d0188d33fb35c2b06d52a7b99d4aabd9f5592af881d67752e81e190f49aee7ec31a834b7220df419c83d2c656ac40540ca20724adc22 WHIRLPOOL 48da117f33432063a72e41440a9cb530fc0569e646210d32468561bfe6d1946b5452a9819e9f3ef6ac09568f91ccd70f032e6eb762375617855acf044386f577
+DIST p95v289.linux64.tar.gz 5710001 SHA256 4f4631df3935397e61d13cbe2ee6b36afd8c402d4b494b6c4bb5df14b45a2a38 SHA512 8ff6c89fa1a0896ebfbc641d273de9ddeb9fa5c3e6425453737291f11baed6e55232e06f26c91c26270d81142f387f4930ce294da0127dd59f249bee76ebdf5e WHIRLPOOL 77808d1d4cce2ddac05ad57ad760cfb469d287cca168dc429687508e9967fea7cc4544aa86f8ae1ccc871f75ad6be7dfc09edb5aae98cf54b9c4424f9785dab1
diff --git a/sci-mathematics/gimps/gimps-28.9.ebuild b/sci-mathematics/gimps/gimps-28.9.ebuild
new file mode 100644
index 00000000000..3ed2d537a9d
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-28.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit pax-utils systemd
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS="license.txt readme.txt stress.txt whatsnew.txt undoc.txt"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}"
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}