summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-18 11:58:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-18 13:17:35 +0200
commitf1beb65db2efa3ed9ee1430d5cd14487aec0d35b (patch)
treea826bbaca3468da486bc408bfd3a013ae9623f8c
parent53226fe6a18b2728506d57ada1b8e6ecb28351e1 (diff)
downloadgentoo-f1beb65db2efa3ed9ee1430d5cd14487aec0d35b.tar.gz
gentoo-f1beb65db2efa3ed9ee1430d5cd14487aec0d35b.tar.xz
dev-ros/geodesy: Bump to 0.5.2.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/geodesy-0.5.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
index dbd638dd68e..9ce69330797 100644
--- a/dev-ros/geodesy/Manifest
+++ b/dev-ros/geodesy/Manifest
@@ -1 +1,2 @@
DIST geographic_info-0.5.0.tar.gz 27102 SHA256 83e046fe4fa92fc9a63727ab8699c0c833f8759ae09c4d07b2c1fd698c73eceb SHA512 c6c4937a7c9873c071be9e3fc4fcdb99f831028dce93793e537f8819e2fb8633b995e7d46d7192ddc3457a3b79d27c54c3e0b6656af30e2daabf1f0e7dff9f05 WHIRLPOOL a6c9f2e6341d1e1e313230bc3f45b8e3d4c0821d1c29ca38e47f8a276d1154d05b3731935efd44722d9f67fa2665ed2db822edc08a3a13a0801a4794443a1ae0
+DIST geographic_info-0.5.2.tar.gz 27336 SHA256 8e5a6b8c63aae9d97a511034536c295f4229e93cc40e60988464dfc591f8564b SHA512 8b512399ef61ebfb9816c613ed4fcde23ec52a9b4bbd1bb7268c8ec7fe03b1a157435fef17b8af72fdf88ce6ed0b9130473183402e0875a25eac0ac46df0d00d WHIRLPOOL c26f0a8fc34eadbcc5fcba70631d539661728a009849841583f69bf72e96bac098da590fa8ae457663124864ede7e33187cbab8e018234ddc8a695466d0dacd9
diff --git a/dev-ros/geodesy/geodesy-0.5.2.ebuild b/dev-ros/geodesy/geodesy-0.5.2.ebuild
new file mode 100644
index 00000000000..d04b778395e
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"