summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-28 07:36:22 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-28 07:36:22 +0100
commitf9f7b06c2ab2266784502ef1cb8c40cba5a92c6c (patch)
treece9d302d2802b84763b95a1650f68550c969d946
parenta4168bbc0ed3a1051ba95392e90f10d6fbeb2fc0 (diff)
downloadgentoo-f9f7b06c2ab2266784502ef1cb8c40cba5a92c6c.tar.gz
gentoo-f9f7b06c2ab2266784502ef1cb8c40cba5a92c6c.tar.xz
dev-ruby/amq-protocol: add 2.1.0
Package-Manager: portage-2.3.3
-rw-r--r--dev-ruby/amq-protocol/Manifest1
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/Manifest b/dev-ruby/amq-protocol/Manifest
index 6902df6d2b6..6e709131e18 100644
--- a/dev-ruby/amq-protocol/Manifest
+++ b/dev-ruby/amq-protocol/Manifest
@@ -1,2 +1,3 @@
DIST amq-protocol-1.9.2.gem 43520 SHA256 79e018cb1a3522967525973ae04d40884620e8d4adca02afeb710f00643a84be SHA512 ea4553b337589589cc89b70e351722ec8af402bd560d73fd35ad41665424a6212e03e26ac86aace5d90f599c7fc2236686fbd83bd75c7023647d95163a2d8573 WHIRLPOOL 5fcfd806b8d84aa64b10bc160fe439dcdff2977b739e04ec23b8f86d94f7a5bee4b95d3688317096b0dcf9214a12921f4b0a4c93c9bd0f6ad3376a6199659189
DIST amq-protocol-2.0.1.gem 43008 SHA256 fd5c0ef0f01c040529a6ddbc12cbdde3e40f63d5045c08b13a03f803df4ef6e6 SHA512 d723899902338562c9b4ad7fdd625e7efa27380b35e9986dfd31f8d334b7cdba4bea47a0f0306a4d24bd14376011287a98d5f31e2d92f89e9fdce7e267d37818 WHIRLPOOL 17657719885871532e1eb99ef4cf69dba84141c895f038c71f22fc054642a3b45cbbaf57bf0429aa4c239309b0c2c78d0ac1d9c6f3cb5a307672af4facce8f46
+DIST amq-protocol-2.1.0.gem 43520 SHA256 d2404af88d5bee649ecf198e9d33d98fe9b9e69dc5f7441e3cdd77322266c395 SHA512 3111c3233a3fdf830cb95d9161132b96035c3835bcf4acd74ec9a915a44096295f5e0cb6b444db7fc4eba84b218800f9c9d33d1cfa5b2d3dcd80dfc65c92c133 WHIRLPOOL 7fc88f56a2fd310dc2925628c9355209ac461ebb4293fc8ed43071c2f9f47ae10799b0084992c16d21ff0fa220e6e55956080682fca043e68ecc00e5a2a7ce41
diff --git a/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild
new file mode 100644
index 00000000000..b204c0505b1
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="https://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}