summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-20 13:08:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-20 13:10:25 +0100
commitfde31ae080d2de3df36e95b04337be56baa9bd67 (patch)
treeacd944617f483ee7b31835f0c210608a32b4b7d5
parentd135373e2df955725ff2217d6ac89759c431018b (diff)
downloadgentoo-fde31ae080d2de3df36e95b04337be56baa9bd67.tar.gz
gentoo-fde31ae080d2de3df36e95b04337be56baa9bd67.tar.xz
net-libs/nghttp2: Bump to version 1.29.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.29.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index faac7be220f..925676c2237 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-1.10.0.tar.gz 2086580 BLAKE2B 207b3906ec3a9e38fbac6331cdb2300c6bf44
DIST nghttp2-1.19.0.tar.gz 2159530 BLAKE2B 09e71408e527f5cd42ed224377042d4b68ff869e86c8727f63f2a4777253da9d03bd2cadfafd655b9984c7b71a52f928906db7b73d3adf74f36e69e28dba5618 SHA512 50f45082f725c237a0e1d25af57992b9cded6c9b68f0aa95c44c16eb4448e05b14e06c853032924d03034115286163de0ad684827cfa5d70896656868fdb4e01
DIST nghttp2-1.27.0.tar.xz 1546064 BLAKE2B c45049b5532076e228b423ad774efb0aa933891c098f9b6dbd4faef1e7b6eb0aa72d765c4c1201235164ee860ac11160dd26fa646637ed2d084d7928928e0252 SHA512 8156ae4084155d000d1655d43790698b0bf89af3ba3a360cedf6a5744aa2ca9485094e65e09da2850ed6dd55479fe33de0948b734b987c85a63f0b3c83dbafd1
DIST nghttp2-1.28.0.tar.xz 1553032 BLAKE2B 81991f7b2ebd74c9a730e22b1f220ef9dbd60f38221313b83db71f92d32590c2a8387412a494be7e33adb2f855b82ed2a9f12c1df40e4602662874f5b1881620 SHA512 c49d4e02ec8e894e01aff0b3573e5ce6a33e37ddbd777f6363a2890681a2d09d9e29794c7a6aaf20dd094b4b6da4b535f3e81ac58ef4164b1f8cca9e0da26ee9
+DIST nghttp2-1.29.0.tar.xz 1544736 BLAKE2B 1708d2c787e27d722aec27890a21e752a9fe66cdcff481615ac0bd9dcc92099946d9e5563a70137029dec54f8cc4244ef22813e0c2010572cd070ff272120bdb SHA512 a518ff1dcc9ae93f8228f4fa9110b9cbc460260a794d455530218c66317c6b96a5b14971aff25428e37326b5ce9f4d8480eefe6fcba17af23efa4ebceb56f23e
diff --git a/net-libs/nghttp2/nghttp2-1.29.0.ebuild b/net-libs/nghttp2/nghttp2-1.29.0.ebuild
new file mode 100644
index 00000000000..b3f6d04b3ea
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.29.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-examples
+ --disable-failmalloc
+ --disable-werror
+ --without-cython
+ --disable-python-bindings
+ $(use_enable cxx asio-lib)
+ $(use_enable debug)
+ $(multilib_native_use_enable hpack-tools)
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ $(multilib_native_use_enable utils app)
+ $(multilib_native_use_with jemalloc)
+ $(multilib_native_use_with xml libxml2)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}