summaryrefslogtreecommitdiff
path: root/app-accessibility/espeak
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/espeak
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/Manifest2
-rw-r--r--app-accessibility/espeak/espeak-1.47.11-r1.ebuild98
-rw-r--r--app-accessibility/espeak/espeak-1.48.04.ebuild98
-rw-r--r--app-accessibility/espeak/metadata.xml11
4 files changed, 209 insertions, 0 deletions
diff --git a/app-accessibility/espeak/Manifest b/app-accessibility/espeak/Manifest
new file mode 100644
index 00000000000..e8492b3bf2e
--- /dev/null
+++ b/app-accessibility/espeak/Manifest
@@ -0,0 +1,2 @@
+DIST espeak-1.47.11-source.zip 2813649 SHA256 9bd4d0569af48a2cb13fa76704dec3124d27025a3f21c87598457976472b360c SHA512 77c3989fbd0e4aadae0da2d7f1c587854895ae103633704ee5b4042b0618897d01edffa80b1f13e6cbf356f2f31beaf4fdb7e90e4ab641d5286d559aaefe932b WHIRLPOOL c26f481d4c3c485ba0eb3fe7ae3bcf36e7001d49e0e27a6f0934fdb9c91cfef4974c1d34daebd0286694346a44c647cfb96769da54536e0b4380778af755673c
+DIST espeak-1.48.04-source.zip 3019245 SHA256 bf9a17673adffcc28ff7ea18764f06136547e97bbd9edf2ec612f09b207f0659 SHA512 f0759e6ace2604c8cbb19e8c3fd4b106edf4dcece247a6677f6b734af7746c35a367126edfbe585396c98f6c54f07e25d64bfab35e258e64f09bd2c0833247fa WHIRLPOOL 259fe408a2d3808f4b1ecec6850262f3b7c0e9a4511fa1bcca414da7d6608e2a0b847a3abb19687ea1cb4e21ca8334fdf0b66b6a78bd363882891b3ebdfb06fc
diff --git a/app-accessibility/espeak/espeak-1.47.11-r1.ebuild b/app-accessibility/espeak/espeak-1.47.11-r1.ebuild
new file mode 100644
index 00000000000..5c7c1e44687
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.47.11-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+
+COMMON_DEPEND=" portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+RDEPEND="${COMMON_DEPEND}
+ media-sound/sox"
+
+S=${WORKDIR}/${MY_P}/src
+
+get_audio() {
+ if use portaudio && use pulseaudio; then
+ echo runtime
+ elif use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ AR="$(tc-getAR)" \
+ AUDIO="$(get_audio)" \
+ all
+
+ einfo "Fixing byte order of phoneme data files"
+ pushd ../platforms/big_endian > /dev/null
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ ./espeak-phoneme-data \
+ ../../espeak-data \
+ . \
+ ../../espeak-data/phondata-manifest
+ cp -f phondata phonindex phontab "../../espeak-data"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ DESTDIR="${D}" \
+ AUDIO="$(get_audio)" \
+ install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_preinst() {
+ local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
+ if [ -d "${voicedir}" ]; then
+ rm -rf "${voicedir}"
+ fi
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}
diff --git a/app-accessibility/espeak/espeak-1.48.04.ebuild b/app-accessibility/espeak/espeak-1.48.04.ebuild
new file mode 100644
index 00000000000..dd706023dd1
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.48.04.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="portaudio pulseaudio"
+
+COMMON_DEPEND=" portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+RDEPEND="${COMMON_DEPEND}
+ media-sound/sox"
+
+S=${WORKDIR}/${MY_P}/src
+
+get_audio() {
+ if use portaudio && use pulseaudio; then
+ echo runtime
+ elif use portaudio; then
+ echo portaudio
+ elif use pulseaudio; then
+ echo pulseaudio
+ else
+ echo none
+ fi
+}
+
+src_prepare() {
+ # gentoo uses portaudio 19.
+ mv -f portaudio19.h portaudio.h
+}
+
+src_compile() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ AR="$(tc-getAR)" \
+ AUDIO="$(get_audio)" \
+ all
+
+ einfo "Fixing byte order of phoneme data files"
+ pushd ../platforms/big_endian > /dev/null
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+ ./espeak-phoneme-data \
+ ../../espeak-data \
+ . \
+ ../../espeak-data/phondata-manifest
+ cp -f phondata phonindex phontab "../../espeak-data"
+}
+
+src_install() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ DESTDIR="${D}" \
+ AUDIO="$(get_audio)" \
+ install
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog.txt ReadMe
+ dohtml -r docs/*
+}
+
+pkg_preinst() {
+ local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
+ if [ -d "${voicedir}" ]; then
+ rm -rf "${voicedir}"
+ fi
+}
+
+pkg_postinst() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn "Since portaudio and pulseaudio are not in your use flags,"
+ ewarn "espeak will only be able to create wav files."
+ ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
+ ewarn "with either portaudio or pulseaudio USE flag enabled."
+ fi
+}
diff --git a/app-accessibility/espeak/metadata.xml b/app-accessibility/espeak/metadata.xml
new file mode 100644
index 00000000000..c07bb6b946a
--- /dev/null
+++ b/app-accessibility/espeak/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">espeak</remote-id>
+ </upstream>
+</pkgmetadata>