summaryrefslogtreecommitdiff
path: root/app-accessibility/sphinx3/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/sphinx3/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/sphinx3/files')
-rw-r--r--app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch18
-rw-r--r--app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch34
2 files changed, 52 insertions, 0 deletions
diff --git a/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch b/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch
new file mode 100644
index 00000000000..0f7733154a5
--- /dev/null
+++ b/app-accessibility/sphinx3/files/sphinx3-0.8-libutil.patch
@@ -0,0 +1,18 @@
+--- src/libs3decoder/libsearch/fsg_history.c
++++ src/libs3decoder/libsearch/fsg_history.c
+@@ -55,7 +55,6 @@
+ #include <kb.h>
+ /*#include <phone.h>*/
+ #include <search.h>
+-#include "libutil.h"
+
+
+ #define __FSG_DBG__ 0
+--- src/libs3decoder/libcfg/s3_cfg_convert.c
++++ src/libs3decoder/libcfg/s3_cfg_convert.c
+@@ -1,5 +1,4 @@
+
+-#include <libutil.h>
+ #include "s3_cfg.h"
+ #include "fsg.h"
+
diff --git a/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
new file mode 100644
index 00000000000..b7b71d97441
--- /dev/null
+++ b/app-accessibility/sphinx3/files/sphinx3-0.8_heap_fix.patch
@@ -0,0 +1,34 @@
+diff -uNr sphinx3-0.8.orig/python/setup.py sphinx3-0.8/python/setup.py
+--- sphinx3-0.8.orig/python/setup.py 2008-12-31 23:20:08.000000000 -0500
++++ sphinx3-0.8/python/setup.py 2011-11-17 09:46:57.000000000 -0500
+@@ -8,15 +8,10 @@
+ define_macros = []
+
+ module = Extension('_sphinx3',
+- include_dirs = ['../../sphinxbase/include',
+- '../include',
+- '/usr/local/include/sphinxbase/',
+- '/usr/local/include/sphinx3',
+- ],
++ include_dirs = ['../include',
++ '@GENTOO_PORTAGE_EPREFIX@/usr/include/sphinxbase'],
+ define_macros = define_macros,
+- library_dirs = ['../../sphinxbase/src/libsphinxbase/.libs',
+- '../src/libs3decoder/.libs',
+- '../../sphinxbase/lib/debug',
++ library_dirs = ['../src/libs3decoder/.libs',
+ '../lib/debug',
+ ],
+ libraries = ['sphinxbase', 's3decoder'],
+diff -uNr sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c sphinx3-0.8/src/libs3decoder/libsearch/vithist.c
+--- sphinx3-0.8.orig/src/libs3decoder/libsearch/vithist.c 2008-12-31 13:27:56.000000000 -0500
++++ sphinx3-0.8/src/libs3decoder/libsearch/vithist.c 2011-11-17 09:46:24.000000000 -0500
+@@ -647,7 +647,7 @@
+ {
+ int32 se, fe, filler_done, th;
+ vithist_entry_t *ve;
+- heap_t h;
++ heap_t *h;
+ s3wid_t *wid;
+ int32 i;
+