summaryrefslogtreecommitdiff
path: root/app-admin/chroot_safe
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/chroot_safe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/chroot_safe')
-rw-r--r--app-admin/chroot_safe/Manifest1
-rw-r--r--app-admin/chroot_safe/chroot_safe-1.4.ebuild36
-rw-r--r--app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch13
-rw-r--r--app-admin/chroot_safe/metadata.xml10
4 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/chroot_safe/Manifest b/app-admin/chroot_safe/Manifest
new file mode 100644
index 00000000000..6b9a3556b32
--- /dev/null
+++ b/app-admin/chroot_safe/Manifest
@@ -0,0 +1 @@
+DIST chroot_safe-1.4.tgz 25886 SHA256 dcdd299e0275838531bbc53de3bb5ecd70f99d0af5fa328e8de761b4de4623bf SHA512 7eee0d8e2c75ccf4bd918f610c21511498a6499b638d09634993a4d6874882a0dbc8c27eea95e9776f1722593e3445399a893557bfa6398a11b85447564dfe61 WHIRLPOOL 749e5924d233e1818330692f1a693e4e41bfb7eca732c97a49c17f69513212a84a2b02feb38f7224c0086a42d547680721712ae92f7776b048a69b77c906f4d9
diff --git a/app-admin/chroot_safe/chroot_safe-1.4.ebuild b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
new file mode 100644
index 00000000000..0618c943d0f
--- /dev/null
+++ b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="a tool to chroot any dynamically linked application in a safe and sane manner"
+HOMEPAGE="http://chrootsafe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN//_}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_compile() {
+ emake CPPFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dolib.so chroot_safe.so
+ dosbin chroot_safe
+ sed -i -e "s:/chroot_safe::" "${ED}"/usr/sbin/chroot_safe \
+ || die "sed chroot_safe failed"
+ doman chroot_safe.1
+ dodoc CHANGES.txt
+}
diff --git a/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch b/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch
new file mode 100644
index 00000000000..e9e94580ac4
--- /dev/null
+++ b/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index ce69ab7..e8542b5 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -12,7 +12,7 @@ install=@INSTALL@
+ all: chroot_safe.so
+
+ chroot_safe.so: chroot_safe.cpp Makefile
+- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(DEFINES) $(SOFLAGS) -o chroot_safe.so $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $(DEFINES) $(SOFLAGS) -o chroot_safe.so $<
+
+ clean:
+ rm -f *.o *.so *~
diff --git a/app-admin/chroot_safe/metadata.xml b/app-admin/chroot_safe/metadata.xml
new file mode 100644
index 00000000000..4145ddd1b33
--- /dev/null
+++ b/app-admin/chroot_safe/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">chrootsafe</remote-id>
+ </upstream>
+</pkgmetadata>