summaryrefslogtreecommitdiff
path: root/app-admin/fam/fam-2.7.0-r7.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/fam/fam-2.7.0-r7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/fam/fam-2.7.0-r7.ebuild')
-rw-r--r--app-admin/fam/fam-2.7.0-r7.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/fam/fam-2.7.0-r7.ebuild b/app-admin/fam/fam-2.7.0-r7.ebuild
new file mode 100644
index 00000000000..0855b9eb072
--- /dev/null
+++ b/app-admin/fam/fam-2.7.0-r7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools multilib-minimal
+
+DEBIAN_PATCH="17"
+DESCRIPTION="FAM, the File Alteration Monitor"
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz
+ mirror://debian/pool/main/f/${PN}/${P/-/_}-${DEBIAN_PATCH}.diff.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="static-libs"
+
+DEPEND="|| ( net-nds/rpcbind >=net-nds/portmap-5b-r6 )
+ !app-admin/gamin"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO README )
+
+src_prepare() {
+ epatch "${WORKDIR}/${P/-/_}-${DEBIAN_PATCH}.diff"
+ edos2unix "${S}"/${P}/debian/patches/10_debianbug375967.patch
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" epatch "${S}"/${P}/debian/patches
+ sed -i configure.ac -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf $(use_enable static-libs static)
+
+ # These are thrown away later
+ if ! multilib_is_native_abi ; then
+ sed -i -e 's/src conf man//' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+
+ sed -i "${D}"/etc/fam.conf \
+ -e "s:local_only = false:local_only = true:g" \
+ || die "sed fam.conf"
+
+ doinitd "${FILESDIR}/famd"
+}