summaryrefslogtreecommitdiff
path: root/app-admin/fleet
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/fleet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/fleet')
-rw-r--r--app-admin/fleet/Manifest2
-rw-r--r--app-admin/fleet/files/fleet.service14
-rw-r--r--app-admin/fleet/files/fleet.socket2
-rw-r--r--app-admin/fleet/files/fleetd.service9
-rw-r--r--app-admin/fleet/fleet-0.11.0-r1.ebuild55
-rw-r--r--app-admin/fleet/fleet-0.11.0.ebuild56
-rw-r--r--app-admin/fleet/fleet-0.11.1.ebuild45
-rw-r--r--app-admin/fleet/fleet-9999.ebuild55
-rw-r--r--app-admin/fleet/metadata.xml17
9 files changed, 255 insertions, 0 deletions
diff --git a/app-admin/fleet/Manifest b/app-admin/fleet/Manifest
new file mode 100644
index 00000000000..b7a98e4a7a9
--- /dev/null
+++ b/app-admin/fleet/Manifest
@@ -0,0 +1,2 @@
+DIST fleet-0.11.0.tar.gz 452750 SHA256 475d92eccfa383d5ed7f48ecca69666c597eb67ed53c41ac443e5f7816110ad7 SHA512 050ef3fba52661caa87e04695dc0120b48d9916b2dc466750f3e735738b2de5e39cc343a8526cbdb8cf2966da89696efdc0a98709732e9c2cb6f7ea6875ef2fc WHIRLPOOL 294d46acba60ef8bae28c3e253ca410281918f4f15b5abb692d7a085e7d3846e28c5c890e677bc77487ed14cf4429dbf38beeb5ef7cc6a2746e583f7f825bd9c
+DIST fleet-0.11.1.tar.gz 453034 SHA256 65965730f70021988ed869e23d9599a2305f24287f3ac67c2b995b05ef28cbe8 SHA512 28e1fc15f634bb5445a5d011dfccae488a873714d868e8632d928a72728380ee7339619e7c057354a154daff71d7260f04c4911e1b371b05c96099ef1d0d9f8d WHIRLPOOL 476ebe9c72b343ecd7dc3f589eed010b5c98651683ee7aee034427702c2779cc16f7f012fa5e2df6d24af9c98731f8e176c3da7acec4ef6753d088ffbf1b14e5
diff --git a/app-admin/fleet/files/fleet.service b/app-admin/fleet/files/fleet.service
new file mode 100644
index 00000000000..1f44fe9df62
--- /dev/null
+++ b/app-admin/fleet/files/fleet.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=fleet daemon
+Wants=etcd.service
+
+Wants=fleet.socket
+After=fleet.socket
+
+[Service]
+ExecStart=/usr/bin/fleetd
+Restart=always
+RestartSec=10s
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/fleet/files/fleet.socket b/app-admin/fleet/files/fleet.socket
new file mode 100644
index 00000000000..4fc446e8fe3
--- /dev/null
+++ b/app-admin/fleet/files/fleet.socket
@@ -0,0 +1,2 @@
+[Socket]
+ListenStream=/var/run/fleet.sock
diff --git a/app-admin/fleet/files/fleetd.service b/app-admin/fleet/files/fleetd.service
new file mode 100644
index 00000000000..ac2a7ff7fee
--- /dev/null
+++ b/app-admin/fleet/files/fleetd.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=fleet
+Wants=etcd.service
+
+[Service]
+ExecStart=/usr/bin/fleetd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-admin/fleet/fleet-0.11.0-r1.ebuild b/app-admin/fleet/fleet-0.11.0-r1.ebuild
new file mode 100644
index 00000000000..47e3f92c358
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.3:=
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}
+
+pkg_postinst() {
+ ewarn "Please read this if you are upgrading from a version <0.10.0-r1."
+ ewarn ""
+ ewarn "Starting with fleet 0.10 the fleetctl utility has"
+ ewarn "'--endpoint=unix:///var/run/fleet.sock' as default argument, which is"
+ ewarn "why we have introduced the fleet.socket unit and renamed the service"
+ ewarn "from fleetd.service to fleet.service. If you run fleet on system"
+ ewarn "startup, please re-enable it via 'systemctl enable fleet'."
+}
diff --git a/app-admin/fleet/fleet-0.11.0.ebuild b/app-admin/fleet/fleet-0.11.0.ebuild
new file mode 100644
index 00000000000..be4655286bb
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.3
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ keepdir /etc/${PN}
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}
+
+pkg_postinst() {
+ ewarn "Please read this if you are upgrading from a version <0.10.0-r1."
+ ewarn ""
+ ewarn "Starting with fleet 0.10 the fleetctl utility has"
+ ewarn "'--endpoint=unix:///var/run/fleet.sock' as default argument, which is"
+ ewarn "why we have introduced the fleet.socket unit and renamed the service"
+ ewarn "from fleetd.service to fleet.service. If you run fleet on system"
+ ewarn "startup, please re-enable it via 'systemctl enable fleet'."
+}
diff --git a/app-admin/fleet/fleet-0.11.1.ebuild b/app-admin/fleet/fleet-0.11.1.ebuild
new file mode 100644
index 00000000000..77c80c4c149
--- /dev/null
+++ b/app-admin/fleet/fleet-0.11.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd vcs-snapshot
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ >=dev-lang/go-1.3:=
+ test? ( dev-go/go-tools )
+"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}
diff --git a/app-admin/fleet/fleet-9999.ebuild b/app-admin/fleet/fleet-9999.ebuild
new file mode 100644
index 00000000000..cf22e122982
--- /dev/null
+++ b/app-admin/fleet/fleet-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-r3 systemd
+
+EGIT_REPO_URI="git://github.com/coreos/fleet.git"
+
+DESCRIPTION="A Distributed init System"
+HOMEPAGE="https://github.com/coreos/fleet"
+SRC_URI=""
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples test"
+
+DEPEND=">=dev-lang/go-1.3:=
+ test? ( dev-go/go-tools )"
+RDEPEND=""
+
+src_compile() {
+ ./build || die 'Build failed'
+}
+
+src_test() {
+ ./test || die 'Tests failed'
+}
+
+src_install() {
+ dobin "${S}"/bin/fleetd
+ dobin "${S}"/bin/fleetctl
+
+ systemd_dounit "${FILESDIR}"/fleet.service
+ systemd_dounit "${FILESDIR}"/fleet.socket
+
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ use examples && dodoc -r examples
+
+ insinto /etc/${PN}
+ newins "${PN}".conf.sample "${PN}".conf
+}
+
+pkg_postinst() {
+ ewarn "Please read this if you are upgrading from a version <0.10.0-r1."
+ ewarn ""
+ ewarn "Starting with fleet 0.10 the fleetctl utility has"
+ ewarn "'--endpoint=unix:///var/run/fleet.sock' as default argument, which is"
+ ewarn "why we have introduced the fleet.socket unit and renamed the service"
+ ewarn "from fleetd.service to fleet.service. If you run fleet on system"
+ ewarn "startup, please re-enable it via 'systemctl enable fleet'."
+}
diff --git a/app-admin/fleet/metadata.xml b/app-admin/fleet/metadata.xml
new file mode 100644
index 00000000000..a86664824b4
--- /dev/null
+++ b/app-admin/fleet/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <maintainer>
+ <email>code@stefanjunker.de</email>
+ <name>Stefan Junker</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">coreos/fleet</remote-id>
+ </upstream>
+</pkgmetadata>