summaryrefslogtreecommitdiff
path: root/app-admin/integrit
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/integrit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/integrit')
-rw-r--r--app-admin/integrit/Manifest2
-rw-r--r--app-admin/integrit/integrit-4.0.ebuild66
-rw-r--r--app-admin/integrit/integrit-4.1-r1.ebuild66
-rw-r--r--app-admin/integrit/metadata.xml8
4 files changed, 142 insertions, 0 deletions
diff --git a/app-admin/integrit/Manifest b/app-admin/integrit/Manifest
new file mode 100644
index 00000000000..fbbe09cd9cd
--- /dev/null
+++ b/app-admin/integrit/Manifest
@@ -0,0 +1,2 @@
+DIST integrit-4.0.tar.gz 266001 SHA256 b0c09cf90404045759571a768a1f4581c0fc7db9a07bc00fef7356c799b200ec SHA512 d05722285e850aea2a07baa8020a379e595f30cfe9d9142d437d6c15f41c5a687ada476971765cab9cf5972be8c4c76a6495c6fb09438d3b35584c8be5d5a4e5 WHIRLPOOL 96ff05fc2b91224c7fd18d95fd46f53f4c6222328f00a12d1611e87b7fcb278b7bb818bf3b94dc4165ec694e6e54bd9c9a2db002b81097536f4b964fc8c2a383
+DIST integrit-4.1.tar.gz 271626 SHA256 2a09b670ee025d6fae756e044f780ccaca90688a97183a350927e3885174223e SHA512 599ae66a193fd87971994f59422e148e1ae01a5ff0fea93a0f2555c972f5254f0213116950766e72c87a57b1bd490f04afd3e0557d25a366c41dbbacc80b6842 WHIRLPOOL e3a31b02ceb32952b492f44db5135f190fbea40a435179d27e92d939935b01ba7f83184b669152ffbae798bdbc510c64bf4842f74320f40d750f4dcfee5d026c
diff --git a/app-admin/integrit/integrit-4.0.ebuild b/app-admin/integrit/integrit-4.0.ebuild
new file mode 100644
index 00000000000..a30152eec41
--- /dev/null
+++ b/app-admin/integrit/integrit-4.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
+ sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+
+ eautoreconf
+}
+
+src_compile() {
+ tc-export AR
+ econf
+ emake || die
+ emake utils || die
+ cd "${S}"/doc
+ emake || die
+ cd "${S}"/hashtbl
+ emake hashtest || die
+ mv README README.hashtbl
+}
+
+src_install() {
+ dosbin integrit || die
+ dolib libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ cd "${S}"/utils
+ dosbin i-viewdb
+ dobin i-ls
+
+ cd "${S}"/hashtbl
+ dolib libhashtbl.a
+ insinto /usr/include
+ doins hashtbl.h
+ dobin hashtest
+ dodoc README.hashtbl
+
+ cd "${S}"/doc
+ doman i-ls.1 i-viewdb.1 integrit.1
+ doinfo integrit.info
+
+ cd "${S}"/examples
+ docinto examples
+ dodoc *
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}
diff --git a/app-admin/integrit/integrit-4.1-r1.ebuild b/app-admin/integrit/integrit-4.1-r1.ebuild
new file mode 100644
index 00000000000..6d3e58184d0
--- /dev/null
+++ b/app-admin/integrit/integrit-4.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="file integrity verification program"
+HOMEPAGE="http://integrit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e "/^CC/d" configure.in hashtbl/configure.in || die
+ sed -i -e "/^AC_PROGRAM_PATH/d" configure.in hashtbl/configure.in || die
+ eautoreconf
+ tc-export AR
+}
+
+src_compile() {
+ emake
+ emake utils
+
+ cd "${S}"/doc && emake
+ cd "${S}"/hashtbl && emake hashtest
+}
+
+src_test() {
+ chmod +x test/test || die
+ default
+}
+
+src_install() {
+ dosbin integrit
+ dolib libintegrit.a
+ dodoc Changes HACKING README todo.txt
+
+ cd "${S}"/utils
+ dosbin i-viewdb
+ dobin i-ls
+
+ cd "${S}"/hashtbl
+ dolib libhashtbl.a
+ insinto /usr/include
+ doins hashtbl.h
+ dobin hashtest
+ newdoc README README.hashtbl
+
+ cd "${S}"/doc
+ doman i-ls.1 i-viewdb.1 integrit.1
+ doinfo integrit.info
+
+ cd "${S}"/examples
+ docinto examples
+ dodoc *
+}
+
+pkg_postinst() {
+ elog "It is recommended that the integrit binary is copied to a secure"
+ elog "location and re-copied at runtime or run from a secure medium."
+ elog "You should also create a configuration file (see examples)."
+}
diff --git a/app-admin/integrit/metadata.xml b/app-admin/integrit/metadata.xml
new file mode 100644
index 00000000000..f22d1250efc
--- /dev/null
+++ b/app-admin/integrit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>forensics</herd>
+ <upstream>
+ <remote-id type="sourceforge">integrit</remote-id>
+ </upstream>
+</pkgmetadata>