summaryrefslogtreecommitdiff
path: root/app-admin/keepassx/keepassx-2.0.3.ebuild
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-08 21:48:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-08 21:49:25 +0200
commite087b94e10ab73faa7f13b6d891caab68ed4d01d (patch)
tree49fbf04abff9c1b2f9eab8ab0c0b03f7048e992b /app-admin/keepassx/keepassx-2.0.3.ebuild
parent6ca7c50770c9b703fa101770b93c544576147fad (diff)
downloadgentoo-e087b94e10ab73faa7f13b6d891caab68ed4d01d.tar.gz
gentoo-e087b94e10ab73faa7f13b6d891caab68ed4d01d.tar.xz
app-admin/keepassx: Bump to version 2.0.3
Package-Manager: portage-2.3.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin/keepassx/keepassx-2.0.3.ebuild')
-rw-r--r--app-admin/keepassx/keepassx-2.0.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/keepassx/keepassx-2.0.3.ebuild b/app-admin/keepassx/keepassx-2.0.3.ebuild
new file mode 100644
index 00000000000..84aeb7d9cdf
--- /dev/null
+++ b/app-admin/keepassx/keepassx-2.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils vcs-snapshot xdg
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+HOMEPAGE="http://www.keepassx.org/"
+SRC_URI="https://www.keepassx.org/releases/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(CHANGELOG)
+
+src_prepare() {
+ xdg_src_prepare
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ xdg_pkg_preinst
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_pkg_postrm
+}