summaryrefslogtreecommitdiff
path: root/app-admin/mcollective
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/mcollective
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/Manifest1
-rw-r--r--app-admin/mcollective/files/mcollectived.initd29
-rw-r--r--app-admin/mcollective/mcollective-2.8.0.ebuild59
-rw-r--r--app-admin/mcollective/metadata.xml14
4 files changed, 103 insertions, 0 deletions
diff --git a/app-admin/mcollective/Manifest b/app-admin/mcollective/Manifest
new file mode 100644
index 00000000000..604338e52c4
--- /dev/null
+++ b/app-admin/mcollective/Manifest
@@ -0,0 +1 @@
+DIST mcollective-2.8.0.tar.gz 718292 SHA256 47084f9285707f2e457850adcf90811f3d39d4f4baa950d822b20b45633db259 SHA512 edc3da334dbd3afd18fcedc675c6498edce1c799d9b472f70ebfe1b972e013cba5217ec492ea4128b15d886edaf283246ba70915180f9a10a67f7c0957fd1c8e WHIRLPOOL 0c6461a43c4533334dee420e7a0debfa8aa2e0079b83407c1313a28689b5ecbd891c94740553947bdce4023786eb0e95e497da73108e283619f358d67dac7c0c
diff --git a/app-admin/mcollective/files/mcollectived.initd b/app-admin/mcollective/files/mcollectived.initd
new file mode 100644
index 00000000000..5744bcd9372
--- /dev/null
+++ b/app-admin/mcollective/files/mcollectived.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the Apache License, Version 2.0
+# $Id$
+
+mcollectived="/usr/sbin/mcollectived"
+pidfile="/var/run/mcollectived"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting mcollectived"
+ ${mcollectived} --pid=${pidfile} --config="/etc/mcollective/server.cfg"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mcollectived"
+ kill `cat ${pidfile}`
+ eend $?
+}
+
+restart() {
+ svc_stop
+ sleep 2
+ svc_start
+}
diff --git a/app-admin/mcollective/mcollective-2.8.0.ebuild b/app-admin/mcollective/mcollective-2.8.0.ebuild
new file mode 100644
index 00000000000..12d75e7738c
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}
diff --git a/app-admin/mcollective/metadata.xml b/app-admin/mcollective/metadata.xml
new file mode 100644
index 00000000000..c35f424e1fe
--- /dev/null
+++ b/app-admin/mcollective/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="client">Install client utilities</flag>
+ </use>
+ <longdescription lang="en">
+ mcollective is a framework to build server orchestration or parallel job
+ execution systems.
+ </longdescription>
+</pkgmetadata>