summaryrefslogtreecommitdiff
path: root/app-admin/mktwpol/mktwpol-1.0.1.ebuild
diff options
context:
space:
mode:
authorJose Maria Alonso Josa <nimiux@gentoo.org>2018-12-19 15:41:39 +0100
committerJose Maria Alonso Josa <nimiux@gentoo.org>2018-12-19 15:42:46 +0100
commitb49496c8265424deb804ab65eb7b746662cd0157 (patch)
tree69aca28cc5e75d1551aad195a85760d25af23e9c /app-admin/mktwpol/mktwpol-1.0.1.ebuild
parent67ac0a08ecbc0a5454fd02117986c254710d40c1 (diff)
downloadgentoo-b49496c8265424deb804ab65eb7b746662cd0157.tar.gz
gentoo-b49496c8265424deb804ab65eb7b746662cd0157.tar.xz
app-admin/mktwpol: Bump version to 1.0.1
Signed-off-by: José María Alonso <nimiux@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.11
Diffstat (limited to 'app-admin/mktwpol/mktwpol-1.0.1.ebuild')
-rw-r--r--app-admin/mktwpol/mktwpol-1.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/mktwpol/mktwpol-1.0.1.ebuild b/app-admin/mktwpol/mktwpol-1.0.1.ebuild
new file mode 100644
index 00000000000..9df4149288a
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Bash scripts to install tripwire and generate tripwire policy files"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/tripwire"
+
+src_prepare() {
+ default
+ sed -i -e 's|/usr/local|/usr|' Makefile || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy and database"
+ elog
+ elog "Mktwpol is packaged with multiple policy-rules-generating files."
+ elog "The default \"rules file\" is installed in /etc/tripwire"
+ elog "Alternatives are installed in /usr/share/doc/${P}"
+ elog "To use an alternative \"rules file\" ..."
+ elog "copy it to /etc/tripwire, uncompress it, and \`touch\` it ..."
+ elog
+ elog "\`cp /usr/share/doc/${P}/mktwpol*.rules.bz2 /etc/tripwire\`"
+ elog "\`bunzip2 /etc/tripwire/mktwpol*.rules.bz2\`"
+ elog
+ elog "mktwpol.sh uses the rules file with the most recent date."
+ elog "Use \`touch\` to choose between multiple rules files."
+ elog
+}