summaryrefslogtreecommitdiff
path: root/app-admin/packagekit-base
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/packagekit-base
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/packagekit-base')
-rw-r--r--app-admin/packagekit-base/Manifest2
-rw-r--r--app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch26
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch17
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch72
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch12
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch13
-rw-r--r--app-admin/packagekit-base/metadata.xml22
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.7.4.ebuild185
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.8.15-r1.ebuild122
9 files changed, 471 insertions, 0 deletions
diff --git a/app-admin/packagekit-base/Manifest b/app-admin/packagekit-base/Manifest
new file mode 100644
index 00000000000..d5a10a1c6fd
--- /dev/null
+++ b/app-admin/packagekit-base/Manifest
@@ -0,0 +1,2 @@
+DIST PackageKit-0.7.4.tar.xz 1493656 SHA256 4112c86d67afbbb9be5d3a706c63c537babbbe1f96e398ae306f5e5e02563a98 SHA512 a2cee60f499ec6c5359f3dc2eddda02cfb9c287f80a6b38aa1d9d87558ce5938ade87ab34f6cb1f9640749a0f19625b44c89f72dea5fbb0cbd5f34aec8dbb9f6 WHIRLPOOL 2827cb038c86164ae58021fafe9f2bbf21e69b5c63c4ef5e0f613806f5725f910af3d5aa51646fd258da9c91b81b086cf9560f66bf042e1cb6d1c25128f984b3
+DIST PackageKit-0.8.15.tar.xz 1506084 SHA256 76aa44994d63b403b1f1154406539951502f5ab92624a8a7dedbeb5437ed0af5 SHA512 d6a1a4582212b02350b8a5ab8413346b0b33a49d329d3c5c4314e3db0c7c40b891d64d275c3acd8eafc45a59462b537cd031919027db2176502861271ce34a02 WHIRLPOOL bcc75e8a05b5616fbec1a2772af53ae51cf8c44a9feda4ca9cff4567f274aed62d3cf01751ab89834f423b77a74dcc1445c32390c323a46bb4340cde568760ce
diff --git a/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
new file mode 100644
index 00000000000..e24faeec9a5
--- /dev/null
+++ b/app-admin/packagekit-base/files/0001-entropy-PackageKitEntropyClient.output-API-update.patch
@@ -0,0 +1,26 @@
+From ee2dfacb275e8145c7ae1ba8da86779054adf902 Mon Sep 17 00:00:00 2001
+From: Fabio Erculiani <lxnay@sabayon.org>
+Date: Fri, 6 Dec 2013 07:40:15 +0100
+Subject: [PATCH] entropy: PackageKitEntropyClient.output API update
+
+---
+ backends/entropy/entropyBackend.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
+index 57b6c59..bec8ef6 100755
+--- a/backends/entropy/entropyBackend.py
++++ b/backends/entropy/entropyBackend.py
+@@ -776,7 +776,8 @@ class PackageKitEntropyClient(Client):
+ def init_singleton(self):
+ Client.init_singleton(self, url_fetcher = PkUrlFetcher)
+
+- def output(self, text, header = "", footer = "", back = False,
++ @classmethod
++ def output(cls, text, header = "", footer = "", back = False,
+ importance = 0, level = "info", count = None, percent = False):
+ """
+ Reimplemented from entropy.output.TextInterface.
+--
+1.8.4.4
+
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch
new file mode 100644
index 00000000000..5c96e51a60e
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-api-change.patch
@@ -0,0 +1,17 @@
+--- a/contrib/browser-plugin/pk-main.c
++++ b/contrib/browser-plugin/pk-main.c
+@@ -503,11 +503,11 @@ NP_Shutdown ()
+ /**
+ * NP_GetMIMEDescription:
+ **/
+-const char *
++char *
+ NP_GetMIMEDescription (void)
+ {
+ g_debug ("NP_GetMIMEDescription");
+- return (const gchar*) "application/x-packagekit-plugin:bsc:PackageKit Plugin";
++ return (gchar*) "application/x-packagekit-plugin:bsc:PackageKit Plugin";
+ }
+
+ /**
+
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch
new file mode 100644
index 00000000000..c3e034d75ff
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.7.x-npapi-sdk.patch
@@ -0,0 +1,72 @@
+--- PackageKit-0.7.4.orig/configure
++++ PackageKit-0.7.4/configure
+@@ -20283,14 +20283,14 @@ if test -n "$PK_BROWSER_PLUGIN_CFLAGS";
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\\
+- mozilla-plugin >= 8.0 \\
++ npapi-sdk \\
+ gio-unix-2.0 \\
+ nspr >= 4.8 \\
+ cairo \\
+ pango \\
+ gtk+-2.0 >= 2.14.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20300,7 +20300,7 @@ if test -n "$PK_BROWSER_PLUGIN_CFLAGS";
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_PK_BROWSER_PLUGIN_CFLAGS=`$PKG_CONFIG --cflags "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20317,14 +20317,14 @@ if test -n "$PK_BROWSER_PLUGIN_LIBS"; th
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\\
+- mozilla-plugin >= 8.0 \\
++ npapi-sdk \\
+ gio-unix-2.0 \\
+ nspr >= 4.8 \\
+ cairo \\
+ pango \\
+ gtk+-2.0 >= 2.14.0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20334,7 +20334,7 @@ if test -n "$PK_BROWSER_PLUGIN_LIBS"; th
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_PK_BROWSER_PLUGIN_LIBS=`$PKG_CONFIG --libs "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20360,7 +20360,7 @@ else
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+ PK_BROWSER_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
+@@ -20368,7 +20368,7 @@ fi
+ gtk+-2.0 >= 2.14.0" 2>&1`
+ else
+ PK_BROWSER_PLUGIN_PKG_ERRORS=`$PKG_CONFIG --print-errors "\
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
new file mode 100644
index 00000000000..69a0fd7e5f4
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.15-qtdbus-annotate.patch
@@ -0,0 +1,12 @@
+Index: PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+===================================================================
+--- PackageKit-0.8.12.orig/src/org.freedesktop.PackageKit.xml
++++ PackageKit-0.8.12/src/org.freedesktop.PackageKit.xml
+@@ -317,6 +317,7 @@
+
+ <!--*****************************************************************************************-->
+ <method name="GetPackageHistory">
++ <annotation name="org.qtproject.QtDBus.QtTypeName.Out0" value="QVariant"/>
+ <doc:doc>
+ <doc:description>
+ <doc:para>
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
new file mode 100644
index 00000000000..59b3ab10964
--- /dev/null
+++ b/app-admin/packagekit-base/files/packagekit-base-0.8.x-npapi-sdk.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 3e8d301..7ba7f4b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -361,7 +361,7 @@ AC_ARG_ENABLE(browser_plugin, AS_HELP_STRING([--enable-browser-plugin],[Build br
+ enable_browser_plugin=$enableval,enable_browser_plugin=yes)
+ if test x$enable_browser_plugin = xyes; then
+ PKG_CHECK_MODULES(PK_BROWSER_PLUGIN, \
+- mozilla-plugin >= 8.0 \
++ npapi-sdk \
+ gio-unix-2.0 \
+ nspr >= 4.8 \
+ cairo \
diff --git a/app-admin/packagekit-base/metadata.xml b/app-admin/packagekit-base/metadata.xml
new file mode 100644
index 00000000000..a63ea63df60
--- /dev/null
+++ b/app-admin/packagekit-base/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <use>
+ <flag name="command-not-found">Enable packagekit support on shell "command not found"</flag>
+ <flag name="cron">Install cron script for auto-update</flag>
+ <flag name="entropy">
+ Enable Entropy backend
+ </flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ Enable introspection
+ </flag>
+ <flag name="pm-utils">
+ Add pm-utils (suspend/resume) functionalities
+ </flag>
+ </use>
+</pkgmetadata>
+
diff --git a/app-admin/packagekit-base/packagekit-base-0.7.4.ebuild b/app-admin/packagekit-base/packagekit-base-0.7.4.ebuild
new file mode 100644
index 00000000000..405764efdf2
--- /dev/null
+++ b/app-admin/packagekit-base/packagekit-base-0.7.4.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+# 0.7.x is untested with Python 3.x
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python nsplugins bash-completion-r1
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="connman cron doc +introspection networkmanager nsplugin pm-utils +policykit entropy static-libs test udev"
+
+CDEPEND="connman? ( net-misc/connman )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.9 )
+ networkmanager? ( >=net-misc/networkmanager-0.6.4 )
+ nsplugin? (
+ >=dev-libs/nspr-4.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.14.0:2
+ x11-libs/pango
+ )
+ policykit? ( >=sys-auth/polkit-0.98 )
+ udev? ( virtual/libgudev )
+ dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.26.1:2
+ >=sys-apps/dbus-1.3.0"
+DEPEND="${CDEPEND}
+ doc? ( dev-util/gtk-doc )
+ nsplugin? ( <net-misc/npapi-sdk-0.27.1 )
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+RDEPEND="${CDEPEND}
+ entropy? ( >=sys-apps/entropy-1.0_rc27 )
+ pm-utils? ( sys-power/pm-utils )
+ >=app-portage/layman-1.2.3
+ >=sys-apps/portage-2.1.9
+ sys-auth/consolekit"
+
+APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
+ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
+for X in ${APP_LINGUAS}; do
+ IUSE=" ${IUSE} linguas_${X}"
+done
+
+S="${WORKDIR}/${MY_P}"
+RESTRICT="test" # tests are failing atm
+
+# NOTES:
+# do not use a specific user, useless and not more secure according to upstream
+# doc is in the tarball and always installed
+# mono doesn't install anything (RDEPEND dev-dotnet/gtk-sharp-gapi:2
+# (R)DEPEND dev-dotnet/glib-sharp:2 dev-lang/mono), upstream bug 23247
+# >=npapi-sdk-0.27.1 has slightly changed API, once it is unmasked in tree
+# drop the npapi-api-change patch below and relax the dependency constraints
+
+# UPSTREAM:
+# documentation/website with --enable-doc-install
+# failing tests
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.x-npapi-sdk.patch #383141
+ epatch "${FILESDIR}"/${PN}-0.7.x-npapi-api-change.patch #416711
+ # http://pkgs.fedoraproject.org/gitweb/?p=PackageKit.git;a=commit;h=0b378668288db34890b82c7be007fc76c7fcd956
+ sed -i -e '/polkit-backend-1/d' configure || die #423431
+}
+
+src_configure() {
+ local myconf=""
+
+ if use policykit; then
+ myconf+=" --with-security-framework=polkit"
+ else
+ myconf+=" --with-security-framework=dummy"
+ fi
+
+ if [[ -z "${LINGUAS}" ]]; then
+ myconf+=" --disable-nls"
+ else
+ myconf+=" --enable-nls"
+ fi
+
+ # localstatedir: for gentoo it's /var/lib but for $PN it's /var
+ # dep-tracking,option-check,libtool-lock,strict,local: obvious reasons
+ # command,debuginfo,gstreamer,service-packs: not supported by backend
+
+ # NOTE: default backend is autodetected at runtime, also
+ if use entropy; then
+ myconf+=" --with-default-backend=entropy"
+ else
+ myconf+=" --with-default-backend=portage"
+ fi
+ econf \
+ ${myconf} \
+ --enable-introspection=$(use introspection && echo -n "yes" || echo -n "no") \
+ --localstatedir=/var \
+ --disable-dependency-tracking \
+ --enable-option-checking \
+ --enable-libtool-lock \
+ --disable-strict \
+ --disable-local \
+ $(use_enable doc gtk-doc) \
+ --enable-command-not-found \
+ --disable-debuginfo-install \
+ --disable-gstreamer-plugin \
+ --disable-service-packs \
+ --enable-man-pages \
+ --enable-portage \
+ $(use_enable entropy) \
+ $(use_enable cron) \
+ --disable-gtk-module \
+ $(use_enable introspection) \
+ $(use_enable networkmanager) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable connman) \
+ $(use_enable pm-utils) \
+ --disable-qt \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ $(use_enable udev device-rebind)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
+ dodoc ChangeLog || die "dodoc failed"
+
+ if use nsplugin; then
+ dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
+ mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
+ "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
+ fi
+
+ if ! use static-libs; then
+ find "${D}" -name *.la | xargs rm || die "removing .la files failed"
+ fi
+
+ # Remove precompiled python modules, we handle byte compiling
+ rm -f "${D}/$(python_get_sitedir)"/${PN}*.py[co]
+
+ newbashcomp "${S}/contrib/pk-completion.bash" ${PN}
+ # Remove bashcomp file installed by build-system
+ rm -f "${D}/bash_completion.d/pk-completion.bash"
+
+ # Remove unwanted PackageKit website stuff
+ rm -rf "${D}/usr/share/PackageKit/website"
+
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN/-base}
+
+ if ! use policykit; then
+ ewarn "You are not using policykit, the daemon can't be considered as secure."
+ ewarn "All users will be able to do anything through ${MY_PN}."
+ ewarn "Please, consider rebuilding ${MY_PN} with policykit USE flag."
+ ewarn "THIS IS A SECURITY ISSUE."
+ echo
+ fi
+}
+
+pkg_prerm() {
+ einfo "Removing downloaded files with ${MY_PN}..."
+ [[ -d "${ROOT}"/var/cache/${MY_PN}/downloads/ ]] && \
+ rm -rf /var/cache/PackageKit/downloads/*
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN/-base}
+}
diff --git a/app-admin/packagekit-base/packagekit-base-0.8.15-r1.ebuild b/app-admin/packagekit-base/packagekit-base-0.8.15-r1.ebuild
new file mode 100644
index 00000000000..dd95a149e3f
--- /dev/null
+++ b/app-admin/packagekit-base/packagekit-base-0.8.15-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# PackageKit supports 3.2+, but entropy and portage backends are untested
+# Future note: use --enable-python3
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools multilib python-single-r1 nsplugins bash-completion-r1
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="bash-completion connman cron command-not-found doc +introspection networkmanager nsplugin entropy static-libs systemd"
+
+CDEPEND="bash-completion? ( >=app-shells/bash-completion-2.0 )
+ connman? ( net-misc/connman )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.9[${PYTHON_USEDEP}] )
+ networkmanager? ( >=net-misc/networkmanager-0.6.4 )
+ nsplugin? (
+ >=dev-libs/nspr-4.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.14.0:2
+ x11-libs/pango
+ )
+ dev-db/sqlite:3
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.32.0:2[${PYTHON_USEDEP}]
+ >=sys-auth/polkit-0.98
+ >=sys-apps/dbus-1.3.0
+ ${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ doc? ( dev-util/gtk-doc[${PYTHON_USEDEP}] )
+ nsplugin? ( >=net-misc/npapi-sdk-0.27 )
+ systemd? ( >=sys-apps/systemd-204 )
+ dev-libs/libxslt[${PYTHON_USEDEP}]
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+RDEPEND="${CDEPEND}
+ entropy? ( >=sys-apps/entropy-234[${PYTHON_USEDEP}] )
+ >=app-portage/layman-1.2.3[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.2[${PYTHON_USEDEP}]"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
+ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
+for X in ${APP_LINGUAS}; do
+ IUSE=" ${IUSE} linguas_${X}"
+done
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.x-npapi-sdk.patch #383141
+
+ # Upstreamed patches
+ epatch "${FILESDIR}/0001-entropy-PackageKitEntropyClient.output-API-update.patch"
+ epatch "${FILESDIR}/${P}-qtdbus-annotate.patch"
+
+ epatch_user
+
+ # npapi-sdk patch and epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(test -n "${LINGUAS}" && echo -n "--enable-nls" || echo -n "--disable-nls") \
+ --enable-introspection=$(use introspection && echo -n "yes" || echo -n "no") \
+ --localstatedir=/var \
+ $(use_enable bash-completion) \
+ --disable-dependency-tracking \
+ --enable-option-checking \
+ --enable-libtool-lock \
+ --disable-local \
+ --with-default-backend=$(use entropy && echo -n "entropy" || echo -n "portage") \
+ $(use_enable doc gtk-doc) \
+ $(use_enable command-not-found) \
+ --disable-debuginfo-install \
+ --disable-gstreamer-plugin \
+ --enable-man-pages \
+ --enable-portage \
+ $(use_enable entropy) \
+ $(use_enable cron) \
+ --disable-gtk-module \
+ $(use_enable introspection) \
+ $(use_enable networkmanager) \
+ $(use_enable nsplugin browser-plugin) \
+ $(use_enable static-libs static) \
+ $(use_enable systemd) \
+ $(use_enable systemd systemd-updates) \
+ $(use_enable connman)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
+ dodoc ChangeLog || die "dodoc failed"
+
+ if use nsplugin; then
+ dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
+ mv "${D}/usr/$(get_libdir)/mozilla/plugins"/* \
+ "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/" || die
+ fi
+
+ if ! use static-libs; then
+ prune_libtool_files --all
+ fi
+}