summaryrefslogtreecommitdiff
path: root/app-admin/xtail
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/xtail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/xtail')
-rw-r--r--app-admin/xtail/Manifest2
-rw-r--r--app-admin/xtail/metadata.xml9
-rw-r--r--app-admin/xtail/xtail-2.1-r1.ebuild36
-rw-r--r--app-admin/xtail/xtail-2.1.ebuild26
4 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/xtail/Manifest b/app-admin/xtail/Manifest
new file mode 100644
index 00000000000..def3b108d4d
--- /dev/null
+++ b/app-admin/xtail/Manifest
@@ -0,0 +1,2 @@
+DIST 20120219-patch-aalto.zip 4991 SHA256 e9904a74aa2309be1ea1d4039fa257d6e7f32bb176dbc0cdf2daa6d3d2390b1b SHA512 ae20448944e25aa04879bdab8d61bd910b1aa6f85c3d8287e712c6d37b1154af480edc6569467e31b3b404d7f90f771ec3e4c20c58132d9125303b40a6f102f2 WHIRLPOOL b3e8e6c5b686acd2c502f7d09f88acce9a5785878a767a4b24a35a0ded49ecd3ed0922075c8fc9bdaea1108a8b9ecd6d330e4671f6b1e8f0ddf1fff530f0e6d0
+DIST xtail-2.1.tar.gz 26769 SHA256 75184926dffd89e9405769b24f01c8ed3b25d3c4a8eac60271fc5bb11f6c2d53 SHA512 a8519969ef960af97c4dcb75c679daa5687f553c909817ede1134dfa5d70ed71c5264f0e61c8c579cc253ccb7739a68c5213811169489a98e676ef8941d9446f WHIRLPOOL 39ab0e4c5379a2acd43bcb29bcd2fce42c7581aea6173fc01bf3ab0075d76ccdbcdaa2c6b8614ee9720c1ac456d9ce3ce0dd4a0078ced413c28d0f599f0fdcf5
diff --git a/app-admin/xtail/metadata.xml b/app-admin/xtail/metadata.xml
new file mode 100644
index 00000000000..b4c2c658bba
--- /dev/null
+++ b/app-admin/xtail/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo.power@gmail.com</email>
+ <name>Iván</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/xtail/xtail-2.1-r1.ebuild b/app-admin/xtail/xtail-2.1-r1.ebuild
new file mode 100644
index 00000000000..b92d58f19f9
--- /dev/null
+++ b/app-admin/xtail/xtail-2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tail multiple logfiles at once, even if rotated"
+HOMEPAGE="http://www.unicom.com/sw/xtail/"
+SRC_URI="http://www.unicom.com/sw/xtail/${P}.tar.gz
+ http://www.unicom.com/files/20120219-patch-aalto.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ epatch ../0001-Use-ISO8601-Fix-Gcc-header-Use-C-c.patch
+ epatch ../0001-xtail.1-remove-SIGQUIT.patch
+ epatch ../xtail_2.1-5-debian-local-changes.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin xtail
+ doman xtail.1
+ dodoc README
+ newdoc ../README README.patches
+}
diff --git a/app-admin/xtail/xtail-2.1.ebuild b/app-admin/xtail/xtail-2.1.ebuild
new file mode 100644
index 00000000000..6d166707ddd
--- /dev/null
+++ b/app-admin/xtail/xtail-2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Tail multiple logfiles at once, even if rotated"
+HOMEPAGE="http://www.unicom.com/sw/xtail/"
+SRC_URI="http://www.unicom.com/sw/xtail/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xtail || die
+ doman xtail.1 || die
+ dodoc README
+}