summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-01 22:11:20 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-01 22:12:24 +0100
commit97096aa781cf8ea1e6ee730c3cb8657e89eaa9ad (patch)
tree1b1640c8cb7af592a57cd3761baa2d7fca0f30ca /app-admin
parentde5b49643ba8d375ca6980493962bbc72ea3c0d5 (diff)
downloadgentoo-97096aa781cf8ea1e6ee730c3cb8657e89eaa9ad.tar.gz
gentoo-97096aa781cf8ea1e6ee730c3cb8657e89eaa9ad.tar.xz
app-admin/calamares: Version bump 2.4.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/calamares/Manifest1
-rw-r--r--app-admin/calamares/calamares-2.4.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
index 367e7bada60..da5b49e8666 100644
--- a/app-admin/calamares/Manifest
+++ b/app-admin/calamares/Manifest
@@ -1,2 +1,3 @@
DIST calamares-2.4.1.tar.gz 2135702 SHA256 ab1ea9c57bfeccea1282813fa67d3ee97ee03f8673af002c13fdda8dc75ef028 SHA512 8720c04cdd6ccc8f18f4a81e9ae213aa1e049f5bcd0af2521161b1adb9faebb217a6a06a30ca37ee7096b200984f271863752cca29f5225196f0306a8ef2ec2c WHIRLPOOL 12be30182b2d2c1c959743d84a0212a9db8ae93ad93c1e377e359a54617914183008b5a4ad6cedce482968bf7b71faa87097c21b8358b3d09ff9258de9223e1a
DIST calamares-2.4.2.tar.gz 2137039 SHA256 4620fd4e9c2d9868e6c20a5c600f123e91080f7ef3a7c6ea55314aa57841b96a SHA512 152857f256f15ff72c44087baf8d4d9d452c5692e131334dd429f40c0e212eac01178352fd17f4020a128f880d3a91dbd634500384d53752d4313a08de816112 WHIRLPOOL 1aa6919a461d5b02a43a4cdbd580a9e7fc9bdc3b048f467f082c4d053c83e5bae5f5777439870828d12153789aac2e4f3b4b6868732dd7c70b0baec3ad4d65c3
+DIST calamares-2.4.3.tar.gz 2141015 SHA256 b4ce2d41feefcfc34d9f14758423307bf3c713f645066cbb028b78df6bba032a SHA512 7a69ee101fc6ad4356a8ad076e6333a1437dff8e1b66bc746241667c837f0816ee0394d397bf6c4a0c4de50f8cc87bef836ce96e409a8a56c5f52dd1635ddf96 WHIRLPOOL a7b88cb548d5e2eb667b2b9106d20ccf218c85546545b1e1f686fef2e0c0c2cfab79b1b95bb2ec4bcbc88a9705e4879a29d87f8e8cfccb8ece2dd34ee77fce17
diff --git a/app-admin/calamares/calamares-2.4.3.ebuild b/app-admin/calamares/calamares-2.4.3.ebuild
new file mode 100644
index 00000000000..82cbabab72b
--- /dev/null
+++ b/app-admin/calamares/calamares-2.4.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="http://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="git://github.com/${PN}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ >=dev-cpp/yaml-cpp-0.5.1
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5]
+ >=sys-libs/kpmcore-2.2.0:5=
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ sys-apps/gptfdisk
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/systemd-boot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ sys-fs/udisks:2[systemd]
+ virtual/udev[systemd]
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+
+ eapply_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWEBVIEW_FORCE_WEBKIT=OFF
+ )
+
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}