summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-19 10:59:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-19 11:03:57 -0500
commitcb3535ebbd663bf4beda6fbad2f8f707b79b0c72 (patch)
tree0d215bdcbfc7e3d15091ecd60caaaf203d750059 /app-admin
parentb8fdb4d4d72fdef7ede55d8fc7f6f02aebbd9162 (diff)
downloadgentoo-cb3535ebbd663bf4beda6fbad2f8f707b79b0c72.tar.gz
gentoo-cb3535ebbd663bf4beda6fbad2f8f707b79b0c72.tar.xz
app-admin/puppet: 6.0.0 bump
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/files/puppet-fix-tests-6.0.0.patch18
-rw-r--r--app-admin/puppet/puppet-6.0.0.ebuild145
3 files changed, 164 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 4264a0cfa2e..51344cad81a 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -3,3 +3,4 @@ DIST puppet-4.10.12.tar.gz 3022218 BLAKE2B 03757857868b1544078ae5e40d6e438631c78
DIST puppet-5.5.2.tar.gz 3036714 BLAKE2B 8be2c2fa7b66a2fd8d413f01afad22f7e0724c31a0a92b777f1b61e2139f14f3284a11cfb52fea8833556208d8bb3e99f20b1ed4fa2816809eaa4b92fa730cd5 SHA512 4995b6b6d1b75d68dd4c8eba37585c0afa88f9c6b78857e837886ea72b373c884182adf8791e0c9f2a5079f22681a40073e512e6b727ecfcaff463c8024cf5db
DIST puppet-5.5.3.tar.gz 3040000 BLAKE2B d2534da5956806e5280c59e82332f1ffca79e72f73b1abb460f155aac936a5ba1719f18dc5742c85fca365ff6b03a602ca0ceaa04714091045ab2afac1b57823 SHA512 14a711002c64f0598930f64e9e2b81c03daddda750860acb349271c1cc9d04c0d149b14817b200dda26f0ca75c3f79593990ecf28a5cca83220a3f5a16eac34d
DIST puppet-5.5.6.tar.gz 3026301 BLAKE2B eb05a0c4eed99ce1ce7a77be76da069be1e4b4f8917206b3811a3a7378c2e39b9c84b560bbcce0bee180ddb502251efb48362dd1c2494c79e6f441cde41a2707 SHA512 53bccc4cf3d4dde3079d96cd28b4cf380d004fdf67da8eaeaf70706ca5e1fe611910042f1aa03453fb29419bb9888a0eeef9a9d64e8f0cfe5d8d7a73e5bf5850
+DIST puppet-6.0.0.tar.gz 2790790 BLAKE2B 1f31839ca21a525ecfbfec2531e8a7570a7c9da5b0e2a8bf3b8641eba9637c61509fb00b3445d0b6ad6b9ef814b9a27850704c897b62ab660eb864f80d990bc8 SHA512 4443f76ec2c8cc23adf112573e5f4e5cef26973c058a70cdf00471b8bd5ac4bc01fb9aa5ba62cb20585266de917c809a439c88a430f051b127d99ef02547c677
diff --git a/app-admin/puppet/files/puppet-fix-tests-6.0.0.patch b/app-admin/puppet/files/puppet-fix-tests-6.0.0.patch
new file mode 100644
index 00000000000..3e51218034c
--- /dev/null
+++ b/app-admin/puppet/files/puppet-fix-tests-6.0.0.patch
@@ -0,0 +1,18 @@
+--- spec/unit/network/http/api/indirected_routes_spec.rb 2018-09-17 19:36:56.000000000 -0500
++++ spec/unit/network/http/api/indirected_routes_spec.rb 2018-09-19 10:52:35.841614932 -0500
+@@ -143,15 +143,6 @@
+ _, _, _, _ = handler.uri2indirection("GET", uri_escaped, params)
+ end
+
+- it "when the environment is unknown should remove :environment from params passed to check_authorization and therefore fail" do
+- handler.expects(:check_authorization).with(anything,
+- anything,
+- Not(has_key(:environment)))
+- expect(lambda { handler.uri2indirection("GET",
+- "#{master_url_prefix}/node/bar",
+- {:environment => 'bogus'}) }).to raise_error(not_found_error)
+- end
+-
+ it "should not URI unescape the indirection key as passed through to a call to check_authorization" do
+ handler.expects(:check_authorization).with(anything,
+ anything,
diff --git a/app-admin/puppet/puppet-6.0.0.ebuild b/app-admin/puppet/puppet-6.0.0.ebuild
new file mode 100644
index 00000000000..81e7876eed5
--- /dev/null
+++ b/app-admin/puppet/puppet-6.0.0.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils user ruby-fakegem versionator
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ dev-ruby/semantic_puppet
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # can't be run within portage.
+ epatch "${FILESDIR}/puppet-fix-tests-6.0.0.patch"
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(get_major_version $v)" = "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}