summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-25 20:01:10 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-25 20:01:10 -0500
commitfea0f7ba531d4d61347df8d667a77b4f8a4b1460 (patch)
treeaccc1742a5e235c5526b0bc3a5cb412c1b985521 /app-admin
parentad47c7bbd758c888ce162ed452e3a9df38293dd4 (diff)
downloadgentoo-fea0f7ba531d4d61347df8d667a77b4f8a4b1460.tar.gz
gentoo-fea0f7ba531d4d61347df8d667a77b4f8a4b1460.tar.xz
app-admin/clustershell: add libressl support
Package-Manager: portage-2.2.24
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/clustershell/clustershell-1.6-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/clustershell/clustershell-1.6-r1.ebuild b/app-admin/clustershell/clustershell-1.6-r1.ebuild
new file mode 100644
index 00000000000..4b248023547
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: test phase
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ local i
+ for i in $(ls -I man "${S}"/doc) ; do
+ dodoc -r doc/${i}
+ done
+ fi
+
+ doman doc/man/man*/*
+
+ insinto /etc/${PN}
+ doins -r conf/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}