summaryrefslogtreecommitdiff
path: root/app-antivirus/skyldav/files
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-02-01 09:03:26 +0100
committerWolfram Schlich <wschlich@gentoo.org>2016-02-01 09:03:41 +0100
commit6ea3e65696e4fb24521636eaf18d8d400ad3d17b (patch)
tree66a24781c4b5f24cb0de0aff496f8fcede40c94f /app-antivirus/skyldav/files
parent91462692d63d107b39332863983359356115ac7f (diff)
downloadgentoo-6ea3e65696e4fb24521636eaf18d8d400ad3d17b.tar.gz
gentoo-6ea3e65696e4fb24521636eaf18d8d400ad3d17b.tar.xz
app-antivirus/skyldav: initial import from my overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-antivirus/skyldav/files')
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.5-conf.patch27
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.5-examples.patch11
-rw-r--r--app-antivirus/skyldav/files/skyldav-0.5-syslog.patch22
-rw-r--r--app-antivirus/skyldav/files/skyldav.confd11
-rwxr-xr-xapp-antivirus/skyldav/files/skyldav.initd26
-rw-r--r--app-antivirus/skyldav/files/skyldav.service-r115
-rw-r--r--app-antivirus/skyldav/files/skyldav.service.conf3
-rw-r--r--app-antivirus/skyldav/files/skyldav.tmpfilesd2
8 files changed, 117 insertions, 0 deletions
diff --git a/app-antivirus/skyldav/files/skyldav-0.5-conf.patch b/app-antivirus/skyldav/files/skyldav-0.5-conf.patch
new file mode 100644
index 00000000000..8255f7a20d1
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.5-conf.patch
@@ -0,0 +1,27 @@
+diff -urN skyldav-0.5.orig/examples/etc/skyldav.conf skyldav-0.5/examples/etc/skyldav.conf
+--- skyldav-0.5.orig/examples/etc/skyldav.conf 2015-02-15 20:32:57.000000000 +0100
++++ skyldav-0.5/examples/etc/skyldav.conf 2016-01-21 14:02:27.656666425 +0100
+@@ -19,14 +19,21 @@
+
+ # Directories that shall not be scanned (including subdirectories)
+ # EXCLUDE_PATH = /var/noscan, /opt/noscan
++EXCLUDE_PATH = /usr/portage, /var/db/pkg, /var/tmp/portage, /var/tmp/binpkgs
+
+ # File systems that are local, virus scan results may be cached.
+ # LOCAL_FS = ext3, ext4, iso9660, tmpfs, vfat
+-LOCAL_FS = ext3, ext4, iso9660, tmpfs, vfat
++LOCAL_FS = ext2, ext3, ext4, xfs, zfs, btrfs, reiserfs, vfat, ntfs, iso9660, tmpfs
+
+ # File systems that shall not be marked for virus scan.
+ # NOMARK_FS = proc, sysfs
+-NOMARK_FS = proc, sysfs, cifs
++#
++# Do not exclude devtmpfs and configs, as userspace could write malware onto them.
++# CIFS is also known to cause problems due to a background daemon, so we exclude it here
++# (https://github.com/xypron/skyldav/commit/63b01b912d3eed80f3db92aec8647770546f5c1c).
++# Note that FUSE file systems are automatically excluded from scanning
++# (https://github.com/xypron/skyldav/issues/3).
++NOMARK_FS = proc, sysfs, devpts, debugfs, securityfs, cgroup, rpc_pipefs, mqueue, autofs, cifs
+
+ # Mounts that shall not be marked for virus scan.
+ # NOMARK_MNT = /mnt/noscan
diff --git a/app-antivirus/skyldav/files/skyldav-0.5-examples.patch b/app-antivirus/skyldav/files/skyldav-0.5-examples.patch
new file mode 100644
index 00000000000..5c614685749
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.5-examples.patch
@@ -0,0 +1,11 @@
+diff -urN skyldav-0.5.orig/Makefile.am skyldav-0.5/Makefile.am
+--- skyldav-0.5.orig/Makefile.am 2015-02-15 20:32:57.000000000 +0100
++++ skyldav-0.5/Makefile.am 2016-01-21 14:11:14.883632470 +0100
+@@ -9,7 +9,6 @@
+ rm -rf doc/doxygen
+
+ install-data-local: \
+- install-skyldav-examples \
+ install-skyldav-conf \
+ install-skyldavnotify-desktop
+
diff --git a/app-antivirus/skyldav/files/skyldav-0.5-syslog.patch b/app-antivirus/skyldav/files/skyldav-0.5-syslog.patch
new file mode 100644
index 00000000000..2e72ce2ab58
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav-0.5-syslog.patch
@@ -0,0 +1,22 @@
+diff -urN skyldav-0.5.orig/src/skyldav/Messaging.cc skyldav-0.5/src/skyldav/Messaging.cc
+--- skyldav-0.5.orig/src/skyldav/Messaging.cc 2015-02-15 20:32:57.000000000 +0100
++++ skyldav-0.5/src/skyldav/Messaging.cc 2016-01-21 14:17:12.492010594 +0100
+@@ -118,15 +118,17 @@
+ break;
+ case INFORMATION:
+ type = "I";
+- syslog(LOG_NOTICE, "%s", message.c_str());
++ syslog(LOG_INFO, "%s", message.c_str());
+ std::cout << message << std::endl;
+ break;
+ case DEBUG:
+ type = "D";
++ syslog(LOG_DEBUG, "%s", message.c_str());
+ std::cout << message << std::endl;
+ return;
+ default:
+ type = " ";
++ syslog(LOG_NOTICE, "%s", message.c_str());
+ std::cout << message << std::endl;
+ break;
+ }
diff --git a/app-antivirus/skyldav/files/skyldav.confd b/app-antivirus/skyldav/files/skyldav.confd
new file mode 100644
index 00000000000..aad4d230590
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.confd
@@ -0,0 +1,11 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Config file for /etc/init.d/skyldav
+
+# Options to pass to the skyldav daemon.
+# Option -d for daemonizing is always passed!
+# See the skyldav(1) man page for more info.
+
+#SKYLDAV_OPTS="-m 1"
diff --git a/app-antivirus/skyldav/files/skyldav.initd b/app-antivirus/skyldav/files/skyldav.initd
new file mode 100755
index 00000000000..fd4bf09f7e3
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SKYLDAV_BIN="/usr/sbin/skyldav"
+SKYLDAV_OPTS="${SKYLDAV_OPTS:--m 2}"
+SKYLDAV_CONFIGFILE="/etc/skyldav.conf"
+SKYLDAV_PIDFILE_DIR="${SKYLDAV_PIDFILE_DIR:-/var/run/${RC_SVCNAME}}"
+SKYLDAV_PIDFILE="${SKYLDAV_PIDFILE:-${SKYLDAV_PIDFILE_DIR}/${RC_SVCNAME}.pid}"
+
+name="${SKYLDAV_BIN##*/}"
+command="${SKYLDAV_BIN}"
+command_args="-d ${SKYLDAV_OPTS}"
+pidfile="${SKYLDAV_PIDFILE}"
+description="Skyld AV is an anti-virus on-access scanner based upon Clam AV and fanotify"
+required_files="${SKYLDAV_CONFIG}"
+
+depend() {
+ use logger
+ need localmount
+}
+
+start_pre() {
+ checkpath -d -m 0755 -o root:root "${SKYLDAV_PIDFILE_DIR}"
+}
diff --git a/app-antivirus/skyldav/files/skyldav.service-r1 b/app-antivirus/skyldav/files/skyldav.service-r1
new file mode 100644
index 00000000000..decd788a9f8
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.service-r1
@@ -0,0 +1,15 @@
+[Unit]
+Description=SkyldAV anti-virus on-access scanning daemon based upon Clam AV and fanotify
+Requires=local-fs.target clamd.service
+After=local-fs.target clamd.service
+Before=multi-user.target
+
+[Service]
+Type=simple
+Environment="SKYLDAV_MESSAGE_LEVEL=2"
+ExecStart=/usr/sbin/skyldav -d -m ${SKYLDAV_MESSAGE_LEVEL}
+#KillMode=process
+#KillSignal=SIGTERM
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-antivirus/skyldav/files/skyldav.service.conf b/app-antivirus/skyldav/files/skyldav.service.conf
new file mode 100644
index 00000000000..79c23a3ff05
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.service.conf
@@ -0,0 +1,3 @@
+[Service]
+# skyldav message level (-m)
+#Environment="SKYLDAV_MESSAGE_LEVEL=1"
diff --git a/app-antivirus/skyldav/files/skyldav.tmpfilesd b/app-antivirus/skyldav/files/skyldav.tmpfilesd
new file mode 100644
index 00000000000..a4f7cdc4742
--- /dev/null
+++ b/app-antivirus/skyldav/files/skyldav.tmpfilesd
@@ -0,0 +1,2 @@
+# skyldav runtime directory for skyldav.pid and log (used by skyldavnotify)
+d /run/skyldav 0755 root root -